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INTRODUCTION
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ABOUT THIS TRAINING WORKBOOK

The scope of this workbook is to familiarize you with the main features of SDL Trados Studio. It contains 
practical, real-life examples of how to leverage SDL Trados Studio to streamline your translation processes. 
This document provides the following:

C General information on CAT technologies

C An overview of the SDL Trados Studio user interface

C An example of how to translate documents using the most commonly used SDL Trados Studio 
features

The main focus of this training guide is on practical life examples, for which training sample files are 
available.

We recommend that you copy the sample files to your Desktop, so that you can find them easily.



Chapter

CAT TECHNOLOGIES OVERVIEW

This chapter gives you a quick overview of the CAT 
technologies referred to in this training workbook:

C Translation memories (TMs)

C Terminology databases

C Alignment

C AutoSuggest dictionaries

C Process and workflow overview

It also explains the scope of the two applications referred to in 
this training workbook:

C SDL Trados Studio

C SDL MultiTerm

2
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WHAT ARE CAT TECHNOLOGIES?

CAT stands for Computer-Aided Translation. This term refers to technologies used to streamline translation 
and localization processes. 

Translation Memories
Translation memories (TMs for short) are databases that store source sentences and their translations as 
segment pairs. Note that as not every text element in a document is a full sentence, translation tools refer 
to segments rather than sentences. Usually a segment is a sentence, but it could also be just a few words, 
like the heading Getting Started. The TM ’remembers’ each segment that is translated, and stores the 
source/target segment pairs in the TM database as translation units (TUs). If an identical or a similar 
segment comes up later, it does not need to be translated from scratch. Instead, the translation can be 
easily retrieved from the TM database.

This technology offers two main advantages:

C Faster turnaround times and cost-savings, as repetitive content can be translated much more 
quickly.

C Better consistency and quality: with TM technology you can make sure that you do not translate 
repeated occurrences of the same sentence differently, which can be confusing to readers.

Terminology Databases (Termbases)
Terminology databases (or termbases) are similar to electronic dictionaries. Rather than storing whole 
segments, they contain single words or expressions. Creating and maintaining termbases is useful for 
storing organization-specific, customer-specific or product-specific terms, which cannot be found in 
standard dictionaries. Example: a termbase used for software localization may contain terms such as dialog 
box, dropdown list, taskbar, etc. 

Termbases can be accessed from within a translation environment, e.g. SDL Trados Studio. In this case, 
the source sentences are automatically searched for relevant terminology in the background. The 
corresponding target terms can then easily be inserted into the translation. This process is called active 
term recognition. This saves you the trouble of having to open a separate application in order to do time-
consuming research work. Termbases offer the following main advantages:

C Cost and time savings, as you avoid tedious extra work such as researching and typing long-winded 
expressions.

C Quality increases, as the same expressions are used consistently throughout a document. 
Termbases help you effectively avoid unnecessary variations, which can be confusing to readers.

C You can create and manage terminology that is customer or product-specific and that cannot be 
found in any standard dictionary.

AutoSuggest Dictionaries
While TMs store whole segments, AutoSuggest dictionaries are used for retrieving segment fragments. 
When you use an AutoSuggest dictionary, it will automatically suggest segment fragments while you are 
typing. For example, when you start typing the letter d, it will suggest relevant expressions that fit the 
current context, e.g. distribution pattern of centipedes. 

AutoSuggest dictionaries are created from translation memories. SDL Trados Studio offers a wizard that 
allows you to select a given TM for creation of an AutoSuggest dictionary. A sophisticated algorithm 
analyzes the TM for useful words, expressions and phrases, which can later be automatically suggested 
while typing. 
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NOTED
The Freelance Edition of SDL Trados Studio allows you to create AutoSuggest dictionaries for a 
duration of 30 days after installation. Users of the Freelance Edition need to purchase an SDL 
AutoSuggest Creator license to be able to continue creating AutoSuggest dictionaries after the initial 
30 days. The Professional Edition of SDL Trados Studio has no restrictions when it comes to using 
and creating AutoSuggest dictionaries.�
�
The SDL Trados Studio Starter Edition does not support the creation or use of AutoSuggest 
dictionaries.�
�
For information on the differences between the three available editions, please refer to 
http://www.translationzone.com/en/products/sdl-trados-studio/#tab2.

Alignment
When you start using a translation memory tool, you will have to fill it with your own translations, as the 
database is empty at the beginning. In order to re-use any translations you have already done, you can use 
the alignment tool to create segment pairs out of two separate documents (source language document and 
translated document). These segment pairs can then be imported into your translation memory. From 
there you can easily re-use your previous translations.

http://www.translationzone.com/en/products/sdl-trados-studio/#tab2
http://www.translationzone.com/en/products/sdl-trados-studio/#tab2
http://www.translationzone.com/en/products/sdl-trados-studio/#tab2
http://www.translationzone.com/en/products/sdl-trados-studio/#tab2
http://www.translationzone.com/en/products/sdl-trados-studio/#tab2
http://www.translationzone.com/en/products/sdl-trados-studio/#tab2
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Process and Workflow overview with SDL Trados Studio
The following diagram summarizes the translation workflow and processes within SDL Trados Studio. It 
shows how the different databases are used in the translation workflow.
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Applications Overview
Below you find an overview of the two applications referred to in this training workbook.

SDL Trados Studio

SDL Trados Studio is the application that this training workbook focuses on. It provides the following 
main functions in an integrated user interface:

C Translation memory capability

C An editing environment for translating and reviewing various source document formats such as 
Microsoft Office, Desktop Publishing, like Adobe InDesign, tagged formats like XML, HTML, etc.

C Automatic quality assurance features

C Functionality for creating and managing projects

This training workbook focuses on the most common functionality for translating documents quickly and 
efficiently in SDL Trados Studio.

NOTED
There are currently three different editions of SDL Trados Studio available: the Professional, Freelance 
and the Starter Edition. For information on the differences between these editions, please refer to 
http://www.translationzone.com/en/products/sdl-trados-studio/#tab2.

SDL MultiTerm

SDL MultiTerm was designed for searching, editing, creating, and maintaining terminology databases. 
This Getting Started training workbook focuses on how to use terminology in the translation process. Note 
that the Getting Started course only contains some basic information on how to use MultiTerm, it does 
NOT include a detailed course on terminology and SDL MultiTerm. SDL MultiTerm is extensively covered 
in dedicated courses for translators and project managers.

http://www.translationzone.com/en/products/sdl-trados-studio/#tab2
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Chapter

THE SDL TRADOS STUDIO 
ENVIRONMENT

This chapter provides a quick overview of the SDL Trados 
Studio user interface. You will learn how to:

C Start the application for the first time

C Select a user profile

C Handle the user interface

3
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INITIAL STARTUP OF THE APPLICATION

After installation, start SDL Trados Studio by clicking the corresponding application icon. To do this take 
the following steps:

1. Select the program group All Programs -> SDL Trados Studio 2019 and click the SDL Trados Studio 
2019 application icon.

2. When starting the application for the first time, you need to activate the product. To do this 
click the Activate button.

NOTED
Without a license, the application will run in demo mode for 30 days.
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3. Enter or paste the activation code that you have received into the Activation code text field, 
then click the Activate button again.�

NOTED
You may use alternative activation options (e.g. a license server) if applicable. If this is the case, click 
the Alternative activation options link, which will open the window shown below. Select the activation 
option that is relevant for you and follow the instructions on the screen.
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4. After successful activation of the product the setup wizard of SDL Trados Studio will open. 
On the welcome screen just click Next.

5. On the Current User Details screen The Name text field should already be pre-filled. Enter 
your e-mail address, which is mandatory information. Then click Next.
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6. You can leave the Default setting on the User Profile unchanged and click Next to continue.

7. You will now be asked whether you want to join the SDL Customer Experience 
Improvement Program. Choose Yes or No, then click Next.
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8. Deselect the Load samples at initial startup option, as the sample project is not required for 
this training course. Then click Finish to finish the setup process.

9. The following window links to an Internet-based Get Started with Studio tutorial and to an 
overview of what is now in the latest Studio version. To close this window and start working 
with the application, click the cross button in the upper-right corner.
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NOTED
The above steps are only necessary when you open the application for the first time.

You should now see the Welcome screen of SDL Trados Studio:

NOTED
The buttons Software Localization and Terminology Management will only work if the corresponding 
applications (i.e. SDL Passolo and SDL MultiTerm) are installed on your PC. 

The SDL Trados Studio User Interface

The Welcome Screen

The Welcome screen of SDL Trados Studio provides quick access to commonly used functions:

C Drag files for translation or browse your computer: allows you to select one or several files for 
translation.

C Open Package: opens a project package sent by a project manager for translation or editing; this 
button can also be used by project managers to open return packages that were sent back by 
translators or reviewers. (This function is covered in Getting Started Part 2.)

C Open GroupShare Project: allows access to an online project on a GroupShare Server where several 
users can work together in one project at the same time. (This function is covered in Getting Started 
Part 2.)
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The Navigation Pane

On the bottom of the Navigation pane you find a set of buttons: Welcome, Projects, Editor, Translation 
Memories. By clicking these buttons you can switch between different views. During this training course 
we will mainly work in the Editor view, which is used to translate, edit and review documents.

NOTED
The content of the Navigation pane changes when you switch to a different view. For example, in the 
Editor or Projects view it offers different functions than in the Welcome view. In the Editor view it 
offers functions relevant for editing and navigating documents, in the Projects view it contains 
functions relevant for managing projects.

The Application Ribbon

On the top of the application window you will find the application ribbon with buttons, which provide 
access to other functions such as Show Shortcuts, Generate AutoSuggest Dictionary, etc.

On the ribbon, you will find, among other things, a button that opens a collection of useful tips. 
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When you move your mouse pointer over the Useful Tips tab on the right-hand side, you can also slide in 
a window that features a list of useful tips & tricks for using Studio. The tips given in this window apply 
to the currently selected view. In the Editor view, for example, you will see tips related to the editing 
environment of Studio.

The ribbon features a number of tabs, e.g. File, Home, View, etc. Each tab provides access to specific 
functions.

For example, click the File tab: 



The  SDL Trados  S tud io  En v i ronment3

3-10     SDL TRADOS STUDIO GETTING STARTED PART 1
SDL plc Confidential. Copyright ¤�2018 SDL plc.

This tab contains the commands for file-related operations such as Save, Close, etc.

Now switch back to the Home tab by clicking the Back button. 

Note that the content of the tabs changes depending on the view that is currently selected. For example, 
in the Welcome view, the Home tab shows different buttons than in the Editor view, which is used for 
translating documents.

Optimizing your Screen Space

You can minimize the Navigation pane on the left-hand side by clicking the Minimize the Navigation Pane 
button. When minimized, the navigation button labels are no longer visible. However, the navigation 
buttons on the bottom of the Navigation pane will still be accessible.
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With the keyboard shortcut F11 you can switch to the Full Screen mode. This will hide elements such as 
the top application bar. By pressing F11 again you can exit the Full Screen mode.

These tips can be helpful especially for users with small screens, e.g. if you are working with a notebook.

MORE INFORMATION
V

C Overview: Introducing SDL Trados Studio

C System Requirements

C Introducing the Views

C Overview: Screen Layout and Functionality

http://producthelp.sdl.com/SDL_Trados_Studio_2015/client_en/introducing/inintroducingsdltradosstudiooverview.htm
http://producthelp.sdl.com/SDL_Trados_Studio_2015/client_en/screen_layout/Overview___Screen_Layout_and_Functionality.htm
http://producthelp.sdl.com/SDL_Trados_Studio_2015/client_en/screen_layout/Overview___Screen_Layout_and_Functionality.htm
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Chapter

CREATING A TRANSLATION 
MEMORY

In this chapter you will learn how to create a new translation 
memory database. We will use this database for translating a 
sample document.

4



Crea t ing  a  T rans la t ion  Memory4

4-2     SDL TRADOS STUDIO GETTING STARTED PART 1
SDL plc Confidential. Copyright ¤�2018 SDL plc.

CREATING A TRANSLATION MEMORY

To create a new translation memory (TM) database take the following steps:

1. Click the Translation Memories button in the lower-left corner to switch to the Translation 
Memories view.

2. Note that the Home tab of the ribbon has changed to show TM-related functions. Click the 
New button, then select New Translation Memory.

3. In the Name text field of the New Translation Memory dialog box enter the name of your 
TM. It is good practice to use descriptive file names for translation memories, which reflect 
the language pair, e.g. EN-DE_Training.

4. The Location text field shows the default path in which the TM file will be stored. The TM 
file will have the extension SDLTM. As you need to select the newly-created TM later for 
translation, we recommend that you specify a location that you can find easily, e.g. your 
Desktop/Sample files.

5. To do this click the Browse button, select your preferred path in the Browse For Folder dialog 
box, and confirm with OK.

6. Make sure that English (United States) is selected in the Source Language dropdown list. 
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7. From the dropdown list Target Language select German (Germany).

NOTED
The sample documents in this course are in English. Therefore it is important that you select English 
as the source language. Some of the examples use German as a target language, so we recommend 
that you also use German in this training course. 

8. There are some more options when you set up a TM, but for this course, we only need the 
basic settings. Click the Finish button to create the TM.

9. On the following page a progress bar will indicate when the TM creation is completed. 
When this is the case, click the Close button.

MORE INFORMATION
V

How to create a local translation memory

http://producthelp.sdl.com/SDL_Trados_Studio_2015/client_en/tm_view/Cre-Man_TM/TMCreate_a_New_Translation_Memory.htm
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The TM has now been created, and is displayed in the Navigation pane on the left-hand side. Since the 
newly-created TM is empty, there are no translation units (TUs) to display. In the following chapter you 
will learn how you use this TM for translation.�



Chapter

TRANSLATING FILES -  MS 
WORD

This chapter provides an example of how to translate a simple 
MS Word document from English into your preferred target 
language. You will learn how to:

C Open a source document and selecting the language 
direction

C Select language resources: translation memory and 
AutoSuggest dictionary

C Navigate in the Editor

C Use matches from the translation memory

C Look up words and expressions through a concordance 
search

C Correct spelling mistakes

C Apply character formatting

C Track your translation progress

C Preview the document in its native format

C Generate the target document in its native format 5
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INTRODUCTION

When you only have one file to translate, you can open the file directly in SDL Trados Studio, the system 
will create a project for your file automatically. But even though a project is created, there are differences 
between translating a single file and setting up a project with the project wizard. The project of a single 
file is limited to this file, new files cannot be added to the project.

Then you choose which translation memory and termbase you want to use. 

For translation, your file will be saved into the internal SDL XLIFF format. This file will contain source 
and target language sentences while you translate.

After translation you save your translated file back to the original file format.

OPENING A FILE

To open the sample document for translation, take the following steps:

Selecting the Document and the Language Pair
1. Switch to the Welcome screen, and then click the Browse link.

2. Browse to the sample files folder in which the sample document is located, e.g. ..\Sample 
Files\Sample documents.

3. Select the file sample.docx by double-clicking it. A window opens that shows the file you have 
just selected. Click TRANSLATE SINGLE DOCUMENT.

4. In the Translation Memory and Document Settings window that appears now, make sure 
that English (United States) is selected as the source language.

NOTED
The source and target languages you select here need to match the language pair of the translation 
memory that you created in the previous chapter (i.e. EN-US_DE).
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5. Select your target language from the Target Language dropdown list, i.e. German (Germany).

Selecting a Translation Memory
1. Add your recently created TM by clicking Use -> File-based Translation Memory.

2. Browse for your TM file, i.e. EN-DE_Training.sdltm, and double-click the file to add it.

3. The selected TM should now be displayed as shown below:

4. Make sure that all four checkboxes are selected, to be able to use this TM for this translation 
(enable), to get segment lookup, to get lookup of segment parts (concordance) and to save 
your translations to this TM (update)
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Selecting an AutoSuggest Dictionary
1. Click the Advanced button to add a sample AutoSuggest dictionary and a termbase. This will open 

the Project Template Setting dialog box.

NOTED
Remember that translation memories allow matching on a sentence (segment) basis, while 
AutoSuggest dictionaries are used for matching segment fragments.

2. Click AutoSuggest Dictionaries on the bottom of the tree on the left-hand side of the dialog 
box. Click the Add button in the lower right corner of the window.

3. Select the AutoSuggest dictionary for your language combination by double-clicking the file, 
e.g. ..\Sample Files\AutoSuggest\AutoSuggest_EN-US_DE-DE.bpm.

Selecting a Termbase
1. Next, select the sample termbase. To do this click All Language Pairs, and then select Termbases.
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2. Select Use -> File-based MultiTerm Termbase.

3. Browse to the Termbase folder of your sample file set (e.g. ..\Sample Files\Termbase) and 
double-click the termbase file Sample.sdltb. 

4. The termbase name should now be displayed in the Project Template Settings window.

5. Click OK again to open the sample source document in the Editor view.

NOTED
Term bases can contain several languages, this is why they are selected in the area All Language 
Pairs, while AutoSuggest dictionaries are always specific to one language pair, therefore you add 
them in the section of this specific language pair.
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MORE INFORMATION
V

How to Add an AutoSuggest Dictionary File for a Language Pair

TRANSLATION EDITOR OVERVIEW

The Editor view presents a side-by-side view of the document:

The source document is displayed in a table, with each sentence (commonly referred to as segment) is 
displayed in a table row. The table has five columns:

1. The first column shows the segment number, by which each segment can be uniquely referred to.

2. The second column shows the source segments.

3. The third column shows the segment status. It contains icons indicating the translation 
status and the translation origin. Here, you can ascertain at a glance whether a translation is 
in draft status, is confirmed, etc. In the beginning, all cells in this column contain a white 
icon, which indicates that all segments are currently untranslated. 

MORE INFORMATION
V

Segment Status Column (Side-by-Side Editor)

4. The fourth column shows the target language. This is where you enter the translations of 
the corresponding source segments.

5. The fifth column shows the document structure information. Here, you can see whether a 
segment is e.g. a heading, a footnote, normal paragraph text. For example, the first segment 
is a heading which is indicated by letter H. Move the mouse pointer over the H in this cell. 
This will display a tooltip with the full description, i.e. Heading. Move the mouse pointer 
over one of the cells below, which contain the letter P. This will show a Paragraph tooltip.

MORE INFORMATION
V

Overview: Side-by-Side Editor Components

The Windows in the Editor
Above the side-by-side editor, you see a number of tabs, most importantly the Translation Results window. 
This is where matches from the TM (if any) are displayed. For the first segment in our sample document 
the message No matches found is displayed, as the TM does not contain a match for the current segment.

Note that the window actually consists of a number of tabs. By clicking the tabs you can switch between 
different windows, e.g. Translation Results, Messages, Concordance Search, and Comments. In the 
course of this exercise you will get to know the function of each tab.

http://producthelp.sdl.com/SDL_Trados_Studio_2015/client_en/setting_preferences/AutoSuggest/Add_Phrase_Mapping_Bilingual_File.htm
http://producthelp.sdl.com/SDL%20Trados%20Studio/client_en/Screen_Layout/Editor_View/Segment_Status_Column.htm
http://producthelp.sdl.com/SDL_Trados_Studio_2015/client_en/screen_layout/TM_View/Overview_TM_Side_by_Side_Editor_Screen_Components.htm
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Each source language sentence (segment) you are going to translate is compared to all source language 
segments in the TM. If a similar segment or the same segment is found, the translation saved with this 
segment will be shown as a translation suggestion. The comparison between the segment to translate and 
the segment in the TM is called „matching”. If you see a suggestion for a translation, a match for the 
source language segment was found in the TM, i.e. the translation from the TM might be useful for the 
translation you have to do now.

In the course of this exercise you will get to know the function of each tab (Translation Results, Messages, 
Concordance Search, and Comments).

MORE INFORMATION
V

C Overview: The Editor View Windows

C Translation Results Window

Next to the Translation Results window you find the Term Recognition window, which displays hits from 
the selected termbase(s). 

MORE INFORMATION
V

Term Recognition Window

You can close, resize, and rearrange all windows to leverage your screen space as required. Try to perform 
the steps below on the Term Recognition window:

C Closing windows: Click the Close (X) button in the upper right corner of the window to close it. 
Instead of the Term Recognition window, the Termbase Search window is displayed, which you can 
close as well. To re-open both windows click the corresponding buttons on the View tab.

http://producthelp.sdl.com/SDL_Trados_Studio_2015/client_en/screen_layout/Editor_View/EVTheEditViewWindowsOverview.htm
http://producthelp.sdl.com/SDL_Trados_Studio_2015/client_en/screen_layout/Editor_View/TermRecWin.htm
http://producthelp.sdl.com/SDL_Trados_Studio_2015/client_en/screen_layout/Editor_View/EVTheEditViewWindowsTranslation_Memory.htm
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C Auto-hide windows: You can auto-hide windows by clicking the Auto Hide button in the upper right 
corner of the window. �

If the Auto Hide button is pointing to the left, the window automatically collapses once you move 
the mouse pointer away. �

�
The name of the hidden window (e.g. Term Recognition), however, will still be displayed in a tab.�
�

When moving the mouse pointer over the tab, the window will reappear. If you move the mouse 
pointer out, the window will hide again. You can disable Auto Hide and fix the position of the 
window by clicking the Auto Hide button once more. When the Auto Hide button icon is pointing 
down, the window stays locked in its current position.�

Moving and docking windows: You can move and rearrange windows within the application or even 
drag the window and position it outside of SDL Trados Studio. For example, you can move a 
window to a second screen. To move a window:

C Move mouse pointer over the title bar of the window and press the left mouse button.

C With the left mouse button pressed, start moving the window to another position. (You can 
also move it to a position outside of the application window.) 

C While you are dragging the window direction indicators will appear on your screen. To dock 
the window, for example, to the right border of SDL Trados Studio, move your mouse pointer 
(with the left mouse button still pressed) over the direction indicator pointing to the right and 
release the left mouse button.

C The window is now docked on the right-hand side of SDL Trados Studio.

C Resetting the window layout: You can always reset the windows layout to the default setting by using 
the Reset Windows Layout command on the View tab.

http://producthelp.sdl.com/SDL%20Trados%20Studio/client_en/Screen_Layout/TM_View/TM_Displaying_and_Managing_Windows.htm
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Navigating in the Editor

Moving from Segment to Segment

You can easily move to the next or previous segment to translate or edit in the Editor simply by using the 
Up/Down Arrow keys on your keyboard. Of course, you can also click inside a segment to select it. The 
selected segment will then be highlighted.

Navigating in the Document Tree

The document tree in the Navigation pane on the left-hand side allows you to quickly jump to a particular 
section in the file. The sample documents contains three main sections. The section headlines are shown 
in the document tree. For example, to jump to the second headline simply click the link Segments with 
Formatting in the document tree. The corresponding segment in the document will then be selected.

Now click the first link in the document tree, i.e. Simple Segments. This will lead you back to the first 
segment.

MORE INFORMATION
V

The Editor View Navigation Pane

TRANSLATING THE DOCUMENT

Now we will start the actual translation work.

Translating the First Segment
In the target column enter the translation for the first segment, e.g. Einfache Sätze. 

NOTED
The letter H in the last column on the right-hand side indicates that this segment is a heading.

Note that as soon as you start typing the translation the icon next to the segment changes to the following 
symbol, which indicates that this segment has been edited:

Note that this symbol also indicates that this segment is still in draft status, and has not been confirmed 
and added to the TM yet.

http://producthelp.sdl.com/SDL_Trados_Studio_2015/client_en/screen_layout/Editor_View/EVScreenLayoutandFunctionalityThe_Navigation_Pane.htm
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Using AutoSuggest

Use the Down key on your keyboard to move to the following segment (This is an example of a new sentence). 
Example for a German translation: Dies ist ein Beispiel für einen neuen Satz. Note that as soon as you start 
entering the translation for the word example, the application suggests the corresponding translation, i.e. 
the German word Beispiel).

NOTED
There will be further examples of hits from the AutoSuggest dictionary, which you can insert into your 
translations.

Instead of typing the whole word, just press the Enter key on your keyboard to insert the suggestion. Then 
go on by completing your target segment. Confirm the translation and save it to your TM by pressing the 
key combination Ctrl+Enter. Observe that icon between the source segment and your translation changes 
to the following:

This icon indicates that your translation has been confirmed and saved to your TM. 

Auto-propagating Translations
The moment you have confirmed the second segment two things happen:

Row 6 is a repetition of the second sentence, which you have just translated. By confirming segment 2, 
your translation has been automatically inserted into segment 6, which is identical to segment 2. This 
feature is called Auto-propagate. It means that whenever you translate or edit one instance of a segment 
that is repeated within your document, all other occurrences of the same segment will be updated 
accordingly.�
Note that the icon next to the translation in row 6 has been changed to the following:

1. This symbol indicates that this segment is 100% identical (i.e. an exact match) to the segment from 
row 2, which you have previously translated and stored in the TM.

Moreover, row 3 now also contains a translation suggestion. The segment is similar to the one in row 2, 
which you have translated and added to the TM. Between the source and target segment you will see the 
following icon:

2. The icon indicates that a translation has been automatically suggested from the TM, but it 
has not been confirmed. Moreover, the 92% match icon shows that this is not an exact 
match, as segment 3 is only similar to a previously translated segment. In the above example 
the degree of similarity is 92%. This means that you need to adapt the suggested translation 
before you confirm and save it to the TM.
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MORE INFORMATION
V

C About Translation Memory Lookups

C About Translation Memory Matches

Editing a Fuzzy Match
When you get a suggestion for an identical segment, we talk about a 100% or exact match. Whenever there 
is a match rate below 100%, this is called a fuzzy match. Take a look at the Translation Results window 
above the document. This window highlights what the differences are between the segment in the 
document and the similar segment from the TM and helps you to determine which changes you need to 
make to the suggested translation.

In the Translation Results window you will find three segments:

1. At the top of the window you see the current segment from the document. 

2. The segment below it is the source segment retrieved from the TM. Differences between the 
segment from the TM and the currently active segment from the document are highlighted 
with strikethrough and underline formatting. In the above example the word an has been 
replaced by another. Note that words that have been removed (e.g. an) are highlighted with 
red strikethrough formatting. Words that have been added (e.g. another) are highlighted with 
blue-green underline formatting.

3. On the right-hand side you find the translation for the segment retrieved from the TM, 
which has also been inserted into the document as a suggestion.

Edit the suggested translation as required by the current source context.

When you edit translations suggested from the TM, the translation origin icon (which shows 92%) becomes 
transparent (see example below). This indicates that a translation has been suggested from the TM, but a 
human translator has modified it.

Spell Check as you Type
If you misspelled a word in the translation this will instantly be highlighted with a wavy red line.

Correct spelling mistakes as follows:

1. Right-click the incorrect word.

2. This opens a context menu with one or more suggested corrections.

http://producthelp.sdl.com/SDL_Trados_Studio_2015/client_en/About/TM/EVWorkingwithTranslationMemoriesAbout_Lookups.htm
http://producthelp.sdl.com/SDL_Trados_Studio_2015/client_en/About/TM/EVWorkingwithTMsAbout_Translation_Memory_Matches.htm
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3. Pick the appropriate suggestion from the context menu to correct the spelling mistake.

Press Ctrl+Enter to confirm and save the modified translation to the TM and to go to the next segment.

MORE INFORMATION
V

C How to Check Spelling As You Type

C How to Enable/Disable Check Spelling As You Type

NOTED
You can also run a spell check on the entire document (i.e. after you have completed the translation) 
by pressing F7. Any spelling suggestions will then be shown for selection in the Spell Checker dialog 
box.

Automatic Number Substitution
Now translate segment 4 (You still owe me 200 dollars), and confirm it with Ctrl+Enter. As soon as you 
confirm the following segment will automatically be translated and marked as a 100% match. 

Note that the only difference between segment 4 and 5 is the number, i.e. 200 vs. 1,000.

Number differences are adapted by SDL Trados Studio automatically. This is why the next segment has 
been marked as a confirmed 100% match so you do not need to modify the segment manually. Just press 
Ctrl+Enter to continue.

NOTED
Segments may contain elements such as numbers, which are called placeables, as they are ’placed’ 
inside the target segment rather than being translated. Note that placeable elements are marked with 
a blue underline in the source segment.

NOTED
If your segment contains more than one number, check carefully that the numbers in the translation 
appear at the correct position, especially if the translation was retrieved as a 100% match.

http://producthelp.sdl.com/SDL_Trados_Studio_2015/client_en/edit_view/EVCheck_Spelling_As_You_Type.htm
http://producthelp.sdl.com/SDL_Trados_Studio_2015/client_en/setting_preferences/Check_Spelling/EnableDisable_CheckSpellingAsType.htm
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Applying Character Formatting
Now translate segment 7, confirm it, and proceed to segment 8:

Note that segments 8 and 9 are almost identical, the only difference is the formatting of the word many. 
When you translate segment 8 and store the translation in the TM, SDL Trados Studio will suggest the 
translation for segment 9. The difference in character formatting is the reason, why you do not get an exact 
match, but a 99% match.

NOTED
TMs do not only take text differences into account, but also character formatting differences.

Modify the suggested translation by applying bold formatting to the target segment:

1. Select the word in the target segment that needs to be formatted (e.g. by double-clicking it).

2. Click the Apply bold button in the ribbon.

3. The selected word has now been formatted accordingly, and you can press Ctrl+Enter to 
proceed.
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Active Terminology Recognition
Take a look at the next segment. You will notice that two words are highlighted with red bracketed lines:�

These lines are used to highlight words that have been found in the terminology database. If a termbase 
has been selected for a project, the source segments will be automatically scanned for any known 
terminology. This feature is called Active Terminology Recognition. Take a look at the Terminology 
Recognition window in the upper right corner of the application. Note that it lists the recognized source 
terms and their translations.

As soon as you start by typing first letter of the translation for application icon, the system will automatically 
offer the full term, which you can insert into your target segment by pressing the Enter key.

Inserting terminology into your target segments is done in the same way as inserting matches offered by 
the AutoSuggest dictionary. In the above example the list contains suggestions both sources, i.e. the 
AutoSuggest dictionary and the termbase. You can easily distinguish between termbase matches and 
AutoSuggest dictionary matches, as they are marked with different icons. 

Terminology matches have the following icon:

AutoSuggest dictionary matches are marked by the following icon:

NOTED
Termbase suggestions are usually more reliable than AutoSuggest dictionary matches, as termbases 
are maintained by a terminologist or translator.
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Applying Character Formatting Through QuickPlace
To apply formatting to words in the translation, we have already used the usual way of marking the word 
and applying formatting with a formatting button. There is another way to apply the formatting 
information from the source segment to words in the target segment, which is called QuickPlace. It works 
the same way as inserting terms from the termbase or AutoSuggest dictionary.

1. Highlight the words in your target segments to which you wish to apply some character formatting.

2. Press the following keyboard combination: Ctrl+, (comma).

This will open a QuickPlace list - with the three types of character formatting that are used in the source 
segment - and which allows you to apply character formatting quickly by using simple keyboard 
commands.

3. Select the required formatting and press Enter on your keyboard.

NOTED
The available types of formatting are sorted in an intelligent manner so that the formatting type that 
is most likely to apply to the selected word(s) is listed first. However, you can select any other 
suggested formatting type from the list by using the Up Arrow and Down Arrow keys on your 
keyboard.

4. Repeat these steps for the other strings in the target segment that need to be formatted, and 
confirm the segment.

Real-time Preview
It is often useful to view the actual MS Word document layout. You can do this any time while you are 
translating:



Tr ans la t ing  F i l es  -  MS Word5

5-16     SDL TRADOS STUDIO GETTING STARTED PART 1
SDL plc Confidential. Copyright ¤�2018 SDL plc.

Move the mouse pointer over the Preview tab on the top right of the application window.

5. The Preview window will slide in. Click the Click here to generate initial preview link in the 
Preview window.

6. This will show the target text in an MS Word preview window.

TIPE
Depending on your screen size and resolution, the preview may turn out too small to read. You can 
resize the Preview window by moving your mouse pointer over the divider of the left-hand side of the 
window and drag it to the left while keeping your left mouse button pressed.



Trans la t ing  F i l es -  MS Word 5

SDL TRADOS STUDIO GETTING STARTED PART 1     5-17
SDL plc Confidential. Copyright ¤�2018 SDL plc.

NOTED
The real-time preview is available for the following file formats: Word, PowerPoint, HTML, and XML. 
All other supported document formats (e.g. Adobe FrameMaker, InDesign etc. can be previewed in 
the native application if installed on your PC).

TIPE
To make sure the text is not cut off, you can select Fit to width from the dropdown list on the bottom 
of the Preview window.�

In the Preview window the currently selected segment from the Editor is highlighted with a grey 
background. That way you can quickly ascertain which part of the document you are currently translating. 
You can also click a segment in the Preview. This will select the corresponding segment in the Editor view.

By default the Preview window is set to auto-hide, i.e. it will disappear once you move the mouse pointer 
away from it.

MORE INFORMATION
V

You can keep the Preview window open while you are translating. That way you can see how the 
actual layout changes segment by segment. To lock the Preview window in place, click the Auto Hide 
button, i.e.:

Inserting Single Tags
Some information in the text will be shown as tags, which are basically placeholders. Tags can appear for 
specific formatting information like subscript or superscript or for elements like footnote or index 
markers. 

http://producthelp.sdl.com/SDL%20Trados%20Studio/client_en/Edit_View/Preview_the_Translation.htm
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Translate and confirm the segment Special Elements (e.g. Sonderfunktionen), and move on to the next 
segment, which is:

This segment contains a fn tag. 

The text of the current segment identical to another one that you translated previously. However, you need 
to insert the tag into the target segment before you proceed. Otherwise, the footnote reference would be 
missing in the target document. To do this take the following steps:

1. Place the cursor at the position in the target segment where the tag needs to be inserted.

2. Press the keyboard combination: Ctrl+, (i.e. the same one you used previously for applying 
character formatting).

3. This will open a QuickPlace list, which contains a footnote reference tag. Press Enter to 
insert the tag into your target segment.�

This will insert the tag into the target segment. Confirm the target segment with Ctrl+Enter 
and proceed.

Concordance Search
In the next segment you find the actual footnote content. The TM does not offer any matching segment 
for this sentence. However, the TM contains the expression access keys, which you have translated in 
previous segments. You can check how access keys was previously translated, by using the concordance 
search feature. A concordance search allows you to select a particular word or expression and look it up in 
the TM:

1. Select the expression access keys in the source segment.

2. Press F3 on your keyboard (or click the right mouse button and select Concordance Search 
from the context menu).
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3. This will display all segment pairs from the TM that contain the selected expression in the 
Concordance Search window. In the source segment(s), the search string is highlighted with 
a yellow background.

NOTED
The concordance search also finds derived and inflected forms of your search string. For example: if 
you select access key, the TM will still find access keys. 

NOTED
The concordance search can also be carried out in the target language. To do this select a string in the 
target language and press F3.

Finish translating this segment, and confirm it with Ctrl+Enter. 

MORE INFORMATION
V

Concordance Search Window (Editor View)

Tracking the Translation Progress
Before you translate the next segment, take a minute to check on your translation progress. When you edit 
or confirm a segment, the status of the document is updated in the status bar on the bottom of the 
application window:

The status bar indicates the percentage of words in the text that have not yet been translated (about 20%), 
that are in draft status (about 14%), and that have been confirmed (about 67%).

Inserting Tag Pairs
The next segments contains a tag pair. Tag pairs consist of an opening and a closing tag, which enclose in 
this example a Web address.

To translate this segment take the following steps:

http://producthelp.sdl.com/SDL_Trados_Studio_2015/client_en/screen_layout/Editor_View/Concordance_Search_Window.htm
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1. First, translate the segment. Just ignore the tags for now.

2. Then highlight the Web address in the target segment.

3. Move the mouse pointer over one of the csf tags in the source segment. (You can select either 
the opening or closing csf tag.

NOTED
csf stands for change style formatting

4. With the Ctrl key pressed click one of the csf tags.

5. This will insert the csf tags around the Web address in your target segment. Repeat steps 3 
and 4 for the field tag pair and the csf tag pair around the rest of the text.

NOTED
Tags here are placeholders for the beginning and end of formatting information, but they do not 
substitute spaces. Please be sure that you are typing all the spaces your text needs.

Ghost Tags
Tags here are placeholders for the beginning and end of formatting information, but they do not substitute 
spaces. Please be sure that you are typing all the spaces your text needs.

Before moving on to the next segment we would like to introduce the concept of ghost tags. Very often tags 
need to occur in pairs, i.e. an opening tag and a closing tag to start and end some formatting. Deleting a 
closing tag, for example, while leaving the opening tag in the translation is likely to cause problems in your 
target document. For example, character formatting may be applied to words that are not supposed to have 
this type of formatting. SDL Trados Studio offers an effective way of drawing your attention to such 
problems. Try the following: 

1. Try to remove the last (i.e. the closing) field tag with the Backspace key.

2. Note that the tag is not fully deleted. Instead, it becomes transparent. This is what is called a 
ghost tag. The ghost tag will actually only be removed if you delete its opening counterpart 
as well. Turning tags into ’ghosts’ is a way of warning users that they are missing a tag. 

3. To restore the tag that you tried to delete, highlight the ghost tag, and click the right mouse 
button. Then select Restore Tags from the context menu, which will restore the tag pair. 
Confirm the segment with Ctrl+Enter to proceed.

Tag View Options
You can change the way tags are displayed using the corresponding ribbon buttons by taking the following 
steps:

1. Select the View tab of the application ribbon.
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2. Click the Full Tag Text button to show the entire tag text, for example, the underline style 
information, the color code, etc.:�

The tags will then be displayed as shown below:

3. Click the No Tag Text button you can minimize the tags as shown below:

4. Switch back to the Partial Tag Text view by clicking the corresponding button. This is the 
recommended default tag display option, as it shows only the names of the tags (e.g. field), 
which gives you a good idea of what a particular tag stands for.

5. Now switch back to the Home tab.

MORE INFORMATION
V

About Ghost Tags

Automated Translations
The last segment only contains a Web address, which should remain unchanged in the target document. 
The entire source segment is considered a placeable element. This is why it has a blue underline. 

The Web address can be easily inserted into the target segment by pressing Ctrl+T. The AT icon between 
the source and the (identical) target segment indicates that this is an Automated Translation suggestion. 
SDL Trados Studio ’assumed’ that the Web address does not need to be localized and translated the 
segment automatically. If the Web address indeed does not need to be changed in the target segment, 
confirm this short segment with Ctrl+Enter.  

http://producthelp.sdl.com/SDL_Trados_Studio_2015/client_en/edit_view/Tags/About_Ghost_Tags.htm
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Finishing the Translation
You have now translated all segments in the document. Note that the status bar on the bottom of the 
application window indicates that we have not confirmed and committed all segments to the TM.

In the above example about 2% of the text are edited, but not confirmed. Remember that you have not yet 
confirmed the first segment. Place the cursor into the target column of the top row. Imagine you are not 
happy with the way you first translated the first segment. Therefore, make a change to the translation (e.g. 
instead of Einfache Sätze write Simple Sätze). After editing the first segment, press Ctrl+Enter to confirm 
and save it to the TM.

NOTED
At this point you can still edit any of the target segments in the Editor view. By pressing Ctrl+Enter, 
you can reconfirm them and commit the changes to the TM. The previously entered translation will 
then be overwritten with the latest version.

SAVING THE DOCUMENT 

Now save the document in SDL Trados Studio:

1. Switch to the Files tab, then click Save.

2.  Save As dialog box. In the text field File name the suggested file name is sample.docx_en-
US_de-DE.sdlxliff. (The actual name depends on your source/target language combination, 
as the language pair is appended to the original document name.

3. Click the Save button to save the document.

NOTED
SDL Trados Studio saves all documents in the bilingual SDL XLIFF format (i.e. not in the native 
format, e.g. DOC or PPT). SDL XLIFF files contain both languages, the source language segments 
and your translated segments. You will learn how to save your translation back into the original file 
format later.

MORE INFORMATION
V

SDL XLIFF File Format

GENERATING A PRINTABLE WYSIWYG PREVIEW

For proofreading purposes, you might want to create a preview of your translated file:

1. Switch to the File tab of the application ribbon.

http://producthelp.sdl.com/SDL_Trados_Studio_2015/client_en/edit_view/XLIFF_File_Format.htm
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2. Then select the Print and View -> View In - > Microsoft Word as Target

3. This will open the target document in MS Word. You can use this preview for printing and 
proofreading the document from paper.

4. Please note that any changes you make to this preview document do not go back into your 
translation environment or the translation memory. Any changes have to be made inside the 
Editor in the SDL XLIFF file.

5. Now close MS Word, and return to SDL Trados Studio.

SAVING THE TRANSLATION IN THE ORIGINAL 
DOCUMENT FORMAT

Finally you save the file back to its native format, here MS Word. To create a DOC file from our SDL XLIFF 
document, take the following steps:

1. Switch to the File tab of the application ribbon.

2. Then click Save Target As.

3.  Save Target As dialog box.

4. Select a location to save your target file.
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5. In the text field File name the original file name, i.e. sample.docx has been entered 
automatically. If you want to save the translated file into the same folder as your original file, 
change the suggested name to e.g. sample_de.docx, so as not to overwrite the original file.

6. Click Save to confirm and save the target MS Word file.

Now that you have finalized the translation, you can close the document in SDL Trados Studio by clicking 
Close on the File tab. 

SUMMARY

C When opening a file for translation you select the source/target language pair, the TM, an 
AutoSuggest dictionary and a termbase.

C Documents are translated in a side-by-side editor, which separates content from layout.

C When you have selected an AutoSuggest dictionary, relevant words and phrases are automatically 
suggested while you are typing. By pressing Enter you can insert these suggestions into your target 
segments.

C Repeated segments are translated automatically once you have translated and confirmed the first 
occurrence. This feature is called auto-propagate.

C The TM recognizes identical segments and translates them automatically by suggesting a 100% 
match.

C When a similar segment is found, a fuzzy match (e.g. a match of 79%) is suggested, which usually 
needs to be modified to fit the current context.

C Translations are entered into the target column on the right-hand side. By pressing Ctrl+Enter you 
confirm your translation, move to the next segment and store the translation in the TM.

C Pressing Ctrl+, opens a list of available character formatting options and/or tags, which you can 
insert into your target segment.

C Any terms that are found in the termbase (if available) are marked with a red bracket. The target 
terms can be easily inserted into your translation just by typing the first letter of the target term and 
by pressing Enter.

C To view the document layout you can view the translation either in the native application (e.g. 
Word). Alternatively you can also open a preview window within Studio, which shows you the 
document layout while you are translating.

C During translation in Studio files are saved to an intermediary, bilingual exchange format called 
SDL XLIFF.

C When the translation is finished, you can generate the target document in its native format (e.g. 
Word).



Chapter

TRANSLATING FILES -  MS 
POWERPOINT

This chapter provides an example of how to translate a simple 
MS PowerPoint document from English into your preferred 
target language. You will learn how to:

C Open a source document through drag & drop

C Have dates auto-localized during translation through 
QuickInsert

C Edit source content

C Merge segments

C Preview MS PowerPoint files for checking the layout

6
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INTRODUCTION

This exercise is similar to the one of the previous chapter. This time, you will translate an MS PowerPoint 
file and learn about some more useful features.

OPENING THE FILE THROUGH DRAG AND DROP

Open the folder ..\Sample Files\Sample documents, select the file sample_answering_machine.pptx in 
Windows Explorer, and drag and drop it into SDL Trados Studio:

1. Make sure that you are in the Editor view. 

2. Drag the above document from Windows Explorer into the area on the Navigation pane that 
is highlighted below:
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3. In the Translation Memory and Document Settings window make sure that the correct 
source/target language pair is selected. Then click OK to open the document.

NOTED
This time you did not have to select the translation memory, the termbase and the AutoSuggest 
dictionary. The application has ‘remembered‘ which resources you used for your specific language 
pair, and automatically selects them for all subsequent documents.

TIPE
If a document is already open, you can also drag and drop the new document anywhere into the 
Editor window.

The document will look as shown below:

NOTED
The information provided in the structure information column on the right-hand side differs from 
what you saw when you opened the MS Word sample document. This time, you find MS PowerPoint-
specific structure element names such as TB (for text box), AS (for AutoShape), etc.
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TRANSLATING THE DOCUMENT

Start by translating segments 1 through 9. This is a revision exercise, in which you can use all the functions 
that you learned about in the previous chapter, e.g. confirming segments, AutoSuggest, QuickPlace, etc.

Auto-localizing Dates
After translating and confirming segment 9, take a look at segment 10, which contains two dates:

Note that the dates are marked with a blue line, which indicates that these are elements that you can place 
inside your target segment by using QuickPlace, i.e. Ctrl+, (rather than typing them manually).

Now take the following steps:

1. Make sure that your cursor is in the corresponding target cell and press Ctrl+,. This will show the 
following QuickPlace list:

2. The QuickPlace list contains the two dates in already localized format. From here, you can 
select the dates and insert them by pressing the Enter key. 

3. Note that by default, Studio uses the long date format, which includes the names of the days. 
Let us assume you want to change the long date format to exclude the name of the date. 
First, close the QuickPlace list by pressing ESC.

4. Click the Project Settings button on the Home tab.
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5. In the Project Settings dialog box click Language Pairs. Then select your current language 
pair, e.g. English (United States) -> German (Germany), and click Translation Memory and 
Automated Translation -> Auto-substitution -> Dates and Times.

6. On the right-hand side, you can select your preferred Long date format, e.g. d.MMM.yyyy 
from the corresponding dropdown list.

7. Click OK to confirm the setting.

8. Click Ctrl+, again to show the QuickPlace list, which now contains the dates in your selected 
format.

9. Translate the current segment by making use of the QuickPlace suggestions. Then confirm 
the segment by pressing Ctrl+Enter.

Editing Source Content
Note that the next segment contains a spelling mistake in the source segment:

You can correct, for example, spelling or grammar mistakes when you happen to notice them during 
translation. Thereby you can avoid adding faulty source content to your TM.

By default, the ability to edit source content is disabled. To enable source editing, take the following steps:
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1. Click the Project Settings button on the Home tab.

2. Click the Project icon in the upper-left corner of the Project Settings dialog box.

3. Activate the Allow source editing check box. Then click OK.

NOTED
Currently, source editing is only supported for MS Word and MS PowerPoint documents.

4. Right-click inside source segment 11, and select Edit source from the context menu.

5. Note that the current source segment is highlighted with a yellow frame. While the frame is 
displayed you can edit the source segment to correct the spelling mistake.

NOTED
This feature is only intended for pure text changes, you cannot insert tags, apply formatting, etc.

Now click inside the target cell, edit the suggested translation as required, and confirm it by pressing 
Ctrl+Enter. Note that this will update your TM to include the corrected source segment.

Source segment 12 contains a grammar mistake (suggest instead of suggests). Right-click the source 
segment and select Edit source from the context menu as before. Then translate and confirm the segment.

Auto-localizing Times
Continue by translating segments 13 through 15. Segment 16 only contains a time specification. You can 
insert the localized time exactly the same way that you used for auto-localizing dates, i.e.:



Trans la t ing  F i l es  -  MS  PowerPo in t 6

SDL TRADOS STUDIO GETTING STARTED PART 1     6-7
SDL plc Confidential. Copyright ¤�2018 SDL plc.

1. Press Ctrl+, to show the QuickPlace list.

2. Press Enter to insert the localized time into your target segment. Then confirm the segment 
by pressing Ctrl+Enter.

Now continue by translating segments 17 and 18.

Merging Segments
Segments 19 and 20 could actually be translated as one segment. However, the application always starts 
a new segment when the previous one ends on a colon and the following segment starts with an upper 
case letter.

Let us assume that you would like to merge these two segments. Take the following steps:

1. Click the number of the first segment that you would like to merge, i.e. 19.

2. Keep the Shift key on your keyboard pressed, and click the number 20. Both segments 
should now be highlighted with different background colors.

NOTED
Make sure that your mouse pointer stays over the segment numbers. Do not move to the actual text.

3. While your mouse pointer is still over the segment number 20, click the right mouse 
button.

4. This opens a context menu, from which you select the Merge Segments command. 
Segments 19 and 20 should now be merged into a single segment.

NOTED
You would not be able to merge, e.g. segment 19 and 21. If you try to do this, the Merge Segment 
command will not be available. The reason for this is the fact that these two segments occur in 
different list items. Note the different LI boxes in the structure recognition column on the right-hand 
side. Segments that belong to different structural elements (e.g. different paragraphs, text boxes, 
table cells, etc.) cannot be merged.
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Inserting Soft Line Breaks
Segment 21 contains a forced line break (soft break). You can display non-printable characters such as 
spaced, protected spaces, tabs, soft breaks, etc. by taking the following steps:

1. Make sure that the Home tab of the application ribbon is selected.

2. Then click the button Show Whitespace Characters.

3. This will display the soft return in the source segment.

4. To insert the soft return in your translation press Shift+Enter.

SAVING THE DOCUMENT

1. Finish translating the document and save it in SDL XLIFF format by pressing Ctrl+S. 

2. This opens the Save As dialog box. In the File name text field the file name 
sample_answering_machine.pptx_en-US_de-DE.sdlxliff will be suggested. 

NOTED
The actual name depends on your source/target language combination, as the language pair is 
appended to the original document name.

3. Click Save to generate the SDL XLIFF file.

PREVIEWING THE TARGET DOCUMENT

Previewing your target content in the actual layout might be particularly important for MS PowerPoint 
files, for example, to check whether the target text fits into the text boxes or whether the layout is disrupted, 
e.g. because the target text is too long. 

To generate the internal preview take the following steps:
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Move the mouse pointer over the Preview tab on the top right of the application window.

1. The Preview window will slide in. Click the Click here to generate initial preview link in the Preview 
window.

2. This will show the target text in PowerPoint proper. Note that the PowerPoint application 
window might not be shown immediately. In this case click the PowerPoint icon in the 
Windows task bar.

3. The PowerPoint document is linked dynamically to the Editor view in Studio. When you 
click a segment in Studio, the preview will jump to the slide in which this segment occurs. 

TIPE
Ideally, you have a second screen to which you can move the PowerPoint preview window. That way 
you can make sure you can always view the document in Studio and in the preview.

SAVING THE TRANSLATION IN THE ORIGINAL 
DOCUMENT FORMAT

Finally you save the file back to its native format, here MS PowerPoint. To create a PPTX file from our SDL 
XLIFF document, take the following steps:

1. Switch to the File tab of the application ribbon.
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2. Then click Save Target As.

3. This opens the Save Target As dialog box.

4. Select a location to save your target file.

5. In the File name text field the original file name, i.e. sample_answering_machine.pptx has 
been entered automatically. If you want to save the translated file into the same folder as 
your original file, change the suggested name to e.g. sample_answering_machine_de.pptx, so 
as not to overwrite the original file.

6. Click Save to confirm and save the target MS PowerPoint file.

Now that you have finalized the translation, you can close the document in SDL Trados Studio by clicking 
Close on the File tab. 

SUMMARY

C Files can be opened just by dragging and dropping them into the Editor of SDL Trados Studio.

C The application ‘remembers‘ which TM(s), termbase(s) and AutoSuggest dictionaries were selected 
last time for the specified language pair. Therefore, there is no need to select these resources again.

C Dates and times can be placed into the target segment using Ctrl+,. Dates and times are 
automatically localized.

C You can activate source editing for particular file types (currently MS Word and MS PowerPoint) to 
correct e.g. spelling mistakes in the source content.

C You can merge segments into one, as long as they do not belong to different structural elements.

C You can insert soft breaks by pressing Shift+Enter.

C You can choose to display whitespace characters by clicking the corresponding button.

C For MS PowerPoint files, you can create a real-time preview in PowerPoint proper.



Chapter

TRANSLATING FILES -  MS 
EXCEL

This chapter provides an example of how to translate a simple 
MS Excel document from English into your preferred target 
language. You will learn how to:

C Copy all source segments into the target cells with one 
click

C Effectively insert terminology into the target segments

C Preview MS Excel files

7
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INTRODUCTION

This exercise is similar to the ones of the previous chapters. This time, you will translate an MS Excel file 
and learn some more useful features.

OPENING THE FILE THROUGH DRAG AND DROP

Make sure that you are in the Editor view. Open the folder ..\Sample Files\Sample documents in Windows 
Explorer, select the file sample_connecting.xlsx, and drag and drop it into SDL Trados Studio.

The document will look as shown below:

NOTED
The information provided in the structure information column on the right-hand side differs from 
what you saw when you opened the MS Word sample document. This time, you find MS Excel-
specific structure element names such as WSN (for worksheet name) and C (for cell).

TRANSLATING THE DOCUMENT

Start by translating segments 1 through 4. This is a revision exercise, in which you can use all the functions 
that you learned in the previous chapter, e.g. confirming segments, AutoSuggest, etc.

Inserting Terminology
Take a look at segment 5, which contains some terms that have been recognized in the termbase. In the 
previous chapters you saw that you can insert the corresponding target terms simply by typing the first 
letter. This will show a list of AutoSuggest hits, which is comprised of entries from the termbase and from 
the AutoSuggest dictionary. The termbase hits are by default listed first. See the example below:�

Let us assume, however, that you would like the list to contain only termbase hits. This can be preferable 
if you want to focus on the termbase entries, and if you want to insert terms without having to type the 
first letter of the corresponding termbase suggestion. To do this take the following steps:

1. If the AutoSuggest list is still open, press ESC to close it.
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2. Now press Ctrl+Shift+L, which will show only the termbase hits:

3. Within this list you can move up and down to select the corresponding target term. Press 
Enter to insert the selected target term into your translation.

Continue by translating and confirming segments 5 through 7.

Copying All Remaining Segments to Target
Segments 8 and 9 contain a number of inline tags:

Rather than inserting the tag pairs one by one, you can just copy the source content for all remaining (i.e. 
still untranslated) segments into the target cell by clicking Copy All Source to Target on the Home tab of 
the application ribbon.

Now you can simply translate by entering your target text between the inline tags.

SAVING THE DOCUMENT

1. Finish translating the document and save it in SDL XLIFF format by pressing Ctrl+S. 

2. This opens the Save As dialog box. In the File name text field the file name 
sample_connecting_machine.xlsx_en-US_de-DE.sdlxliff will be suggested. 

3. Click Save to generate the SDL XLIFF file.

PREVIEWING THE TARGET DOCUMENT

Note that for MS Excel files no internal (or real-time) preview is available. MS Excel documents can only 
be previewed in MS Excel proper.

To preview the document, take the following steps:

1. Switch to the File tab of the application ribbon.

2. Then select Print and View - > View In -> MS Excel as Target.
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This opens the target document in MS Excel proper. Here you can, for example, check the layout, print the 
document for proofreading from paper, etc.

Close MS Excel, and switch back to SDL Trados Studio.

SAVING THE TRANSLATION IN THE ORIGINAL 
DOCUMENT FORMAT

Finally you save the file back to its native format, here MS Excel. To create an XLSX file from our SDL 
XLIFF document, take the following steps:

1. Switch to the File tab, and then click Save Target As.

2. This opens the Save Target As dialog box.

3. Select a location to save your target file.

4. In the File name text field the original file name, i.e. sample_connecting.xlsx has been entered 
automatically. If you want to save the translated file into the same folder as your original file, 
change the suggested name to e.g. sample_connecting_de.xlsx, so as not to overwrite the 
original file.

5. Click Save to confirm and save the target MS Excel file.

Now that you have finalized the translation, you can close the document in SDL Trados Studio with the 
Close command on the File tab.
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SUMMARY

C To retrieve only the termbase suggestions use the keyboard shortcut Ctrl+Shift+L.

C You can copy all source content into (untranslated) target cells by clicking Copy All Source to Target 
on the Home tab of the application ribbon.
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Chapter

TRANSLATING FILES -  PDF

This chapter provides an example of how to translate a simple 
PDF document from English into your preferred target 
language. You will learn how to:

C Open a PDF document for translation

C Analyse the document against the selected TM

C Read the analysis results

C Preview the target document

8
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INTRODUCTION

Note that although SDL Trados Studio can process PDF files, translating PDF should only be considered 
when the original format (e.g. MS Word, Adobe InDesign, etc.) is no longer available. When opening a 
PDF document, SDL Trados Studio extracts the translatable content and converts it to MS Word format.

OPENING THE FILE THROUGH DRAG AND DROP

Open the folder ..\Sample Files\Sample documents, select the file sample_PDF.pdf in Windows Explorer, and 
drag and drop it into the Editor of SDL Trados Studio. When opening the PDF file in SDL Trados Studio, 
it will automatically be converted to DOCX in the background. The document will look as shown below:

NOTED
The translatability of the resulting document depends on the quality of the PDF file. As mentioned 
above, PDF should only be processed if the original format is no longer available. 

Analyzing Files
This sample document contains a lot of segments that are similar or identical to the MS PowerPoint file 
that you translated in a previous chapter. 

Let us assume that you would like to ascertain the scope of your current translation job before you actually 
start working on the document. Moreover, you would like to determine how many exact and fuzzy matches 
you can retrieve from the TM. 

Running the File Analysis

To do this you can have the current file analyzed as follows:

1. Select the Home tab of the application ribbon.

2. Click the Batch Tasks button.
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3. This opens a list of available batch tasks below the Batch Tasks button. Here, you need to 
select Analyze Files.

NOTED
As you can see, there are many more batch tasks available. However, in this training course we will 
only cover the file analysis. Other batch tasks are covered in continuative courses.
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4. This will open the Batch Processing window. Click Finish to start the analyze task.

5. When the process is finished, click Close.

6. You will now be prompted to re-open the file. Click Yes to confirm.

Viewing the Analysis Result

To view the result of the file analysis, take the following steps:

1. Switch to the Reports view by clicking the corresponding button in the Navigation pane.
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2. Take a look at the Totals section of the report on the right-hand side:

The above report can be read as follows:

C The last (Total) row in the above example displays the total number of segments (20) and words 
(128). 

C The row New/AT shows the number of segments and words for which no TM matches have been 
found. 

C In the rows above New/AT you find the number of segments and words for which fuzzy matches 
have been identified. 

C The row 100% shows the number of exact matches. 

C The row Context Matches shows the number of so-called context matches, which are very similar to 
the 100% matches, and therefore can also be counted as exact matches.

TIPE
The Getting Started Part 2 training course provides more detailed information on context matches.

NOTED
The report also shows automated translation matches (AT). These refer to translation suggestions 
provided by an online machine translation provider such as SDL Language Cloud. AT matches, 
however, are not covered in this course.

From this analysis result you can deduce that for most segments in the current document you will be 
offered either exact or fuzzy matches. There is a fairly low percentage of new content, here only about 12%.
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TRANSLATING THE DOCUMENT

Now switch back to the document by clicking the Editor button in the Navigation pane.

Restrictions when Merging Segments
Take a look at segments 1 and 2. This is an example of a segment that has been broken up in the middle 
when the PDF was converted to DOCX.

You might now want to merge these segments as you have learned before, i.e. by selecting segments 1 and 
2 and right-clicking. However, in this case, the context menu will show the Merge Segments command as 
inactive:

The reason for this is that segment 2 has ended up in a different paragraph (as shown in the structure 
information column on the right-hand side). Therefore, merging this segment with the one above is not 
possible.

In this case, you can allow merging across paragraphs by taking the following steps:

1. In the ribbon, click Project Settings.

2. In the Project Settings window, click Project.

3. Activate the check box Allow Source editing.
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4. Then check the box Enable merging segments across paragraphs.

5. Click OK to confirm and to close the Project Settings window.

6. Try merging segments 1 and 2 again. Note that the Merge Segments command is now 
available.

7. After merging, you can translate the expanded segment 1. Note that segment 2 appears to 
have disappeared:

When merging segments 1 and 2 across the paragraph mark, the content of segment 2 has been copied 
into segment 1, leaving segment 2 empty. By default, SDL Trados Studio hides empty lines that are created 
when merging across paragraph marks. However, you can display the empty segment 2 by taking the 
following steps:
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1. Select File - > Options.

2. In the Options window select Editor -> Automation. Then uncheck the box Hide empty 
segments that have been merged.

3. Click OK to confirm and to close the Options window.

4. Note that the empty segment is now shown displayed. It is also locked, to prevent you from 
accidentally enter target text, while there is no more source text to translate.

Note that these empty lines in SDL Trados Studio lead to redundant paragraph marks in the target 
document, which will become obvious in the document preview.

PREVIEWING THE TARGET DOCUMENT

As the PDF document is actually processed as DOCX, previewing works the same way as for MS Word 
documents.

NOTED
PDF documents are always treated as MS Word documents, even when the PDF files originate from 
other application such as Adobe FrameMaker or InDesign.
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External Preview
To open the target document in MS Word proper, take the following steps:

1. Switch to the File tab of the application ribbon.

2. Then select Print and View -> View In -> Microsoft Word as Target.

3.  This opens the target document in MS Word proper. Here you can, for example, check the 
layout, print the document for proofreading from paper, etc. Note that the target document 
contains an additional empty paragraph:

4. Merging across paragraphs can lead to redundant paragraph marks, empty bullet points, 
etc., which then have to be removed in the final target file. 

5. Close MS Word, and switch back to SDL Trados Studio.

Real-time Preview
To generate the real-time preview take the following steps:
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Move the mouse pointer over the Preview tab on the top right of the application window.

6. The Preview window will slide in. Click the Click here to generate initial preview link in the 
Preview window.

7. This will show the target text in a MS Word preview window. If the preview document is 
hard to read, resize the window or select e.g. 75% from the zoom dropdown list on the 
bottom of the preview window.

TIPE
If you have closed the Preview window in the previous exercise, the Preview tab is no longer available. 
In this case, click Reset Window Layout on the View tab of the application ribbon. Then confirm with 
OK. This will restore all windows to their default settings.
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SAVING THE TRANSLATION IN THE ORIGINAL 
DOCUMENT FORMAT

Finally you save the file back to its native format, here MS Word (i.e. not PDF). To create a DOCX file from 
our SDL XLIFF document, take the following steps:

1. Select the File tab of the application ribbon.

2. Then click Save Target As. This opens the Save Target As dialog box.

3. Select a location to save your target file.

4. In the File name text field the original file name, i.e. sample_PDF.docx has been entered 
automatically. You may want to change the name of the target file, e.g. to 
sample_PDF_de.DOCX.

NOTED
The file sample_PDF.docx is available in the folder where the original PDF document resides, as the 
PDF has been converted in the background to DOCX when you opened the file.

5. Click Save to generate the target MS Word target file.

NOTED
Empty lines that result from merging across paragraphs might have to be removed manually from 
the target file.

Now that you have finalized the translation, you can close the document in SDL Trados Studio by clicking 
Close on the File tab.
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SUMMARY

C SDL Trados Studio can process PDF documents, however, you should only use this option if the 
original document format, e.g. MS Word, Adobe InDesign, is no longer available.

C When opening a PDF document SDL Trados Studio converts the file to DOCX in the background.

C As the PDF file is always processed as DOCX, the same preview options than for MS Word are 
available, i.e. real-time preview and preview in MS Word proper.

C If you do not want segment pairs to be stored in the TM, just do not confirm them, i.e. leave them in 
draft status.

C The target file will always be saved in DOCX format (i.e. not PDF).

C Segments of different paragraphs, table cells, etc. can be merged when you configure the project 
settings accordingly. Merging across paragraphs leads to redundant lines, empty bullet points, etc., 
which then have to be cleaned up in the target document.



Chapter

SEGMENT FRAGMENT 
MATCHING

This chapter provides examples of how to retrieve segment 
fragments from your translation memory during translation. 
You will learn how to:

C Retrieve segment fragments from full TUs

C Enable and configure retrieval of segment fragments 
from partial TUs

C Prepare your translation memory for segment fragment 
retrieval from partial TUs

9



Ret r i ev ing  Segment  F ragments9

9-2     SDL TRADOS STUDIO GETTING STARTED PART 1
SDL plc Confidential. Copyright ¤�2018 SDL plc.

WHAT ARE SEGMENT FRAGMENTS?

Up to now you have learned how to retrieve full segment matches from a TM. For example, let us assume 
that you have to translate a segment like:

Click here to open the dialog box. 

For this segment, your TM might give you full segment matches and their corresponding translations, 
such as:

Click here to close the dialog box. -> Klicken Sie hier, um das Dialogfeld zu schließen.

Click to open the dialog box. -> Klicken Sie, um das Dialogfeld zu öffnen.

etc.

However, the TM does not give you segment fragments such as:

Click here

the dialog box

to close

etc.

You have learned that terminology and segment fragments can, however, be suggested from termbases 
and AutoSuggest dictionaries. This is very convenient, as relevant terminology is automatically suggested 
while you are typing. However, it might be that resources such as AutoSuggest dictionaries and termbases 
are simply not available, and that the only thing you have is a TM.

In this case, it would (of course) be good if the TM could also suggest segment fragments in addition to 
full segment matches - similar to the way AutoSuggest dictionaries and termbases provide matching 
fragments.

The exercises in this chapter show you how to obtain useful fragment matches from your TM.

SEGMENT FRAGMENTS FROM WHOLE TUs

There are two kinds of segment fragment matches:

1. Fragments from full TUs

2. Fragments from partial TUs

We will start by showing you how fragments from full TUs work. Imagine that the following (very short) 
segment pair is already contained in your TM:

Dialog box -> Dialogfeld

Let us assume that you now need to translate a segment like:

A dialog box will pop up.

This new segment contains the term dialog box, which is stored as a separate unit in the TM. In this case, 
your TM can automatically suggest the required term while you are translating. The good news is that this 
works out-of-the box, i.e. no special settings are required. Every TM that you create will automatically be 
enabled for what we call whole TU fragment matching. This, of course, also applies to the training TM 
that you created at the beginning of the course, and that you have been using until now.
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To see how fragment matching for whole TUs works, take the following steps:

1. Open the sample file ..\Sample Files\Fragment matching\01 - Whole Fragment Matches.docx for 
translation.

2. We are going to use the same TM, AutoSuggest dictionary, and termbase as in all previous 
exercises, so there is no need to change any settings. In the Editor view the document will 
look like this:

3. Translate and confirm the first two segments. When come to segment 3, you should see the 
following:,�

4. The window above the document shows a segment fragment match, as you have translated 
the term Grammar Checker in the first segment.

5. Translate the current segment, and watch what happens when you start typing the target 
equivalent for the term Grammar checker:�

The target term will be automatically suggested as soon as you type the first letter. Press 
Enter to insert the suggested target term.
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6. Finish translating the current segment, then confirm it. In segment 5, two fragment 
matches have been found from previous segments:

7. When translating this segment, you can use the fragment matches that are automatically 
suggested while you are typing. Translate the current segment using the fragment matches, 

and confirm it.�

NOTED
When you are using different AutoSuggest providers, i.e. AutoSuggest dictionary, TM fragments, and 
termbases, the AutoSuggest list might contain hits from several sources. The hits are then marked 
with different icons. TU fragment matches are marked with the following icon:

8. Translate the rest of the document, then save and close it.

SEGMENT FRAGMENTS FROM PARTIAL TUs

In the previous section, you saw what happens when the whole content of a (small) TU comes up in a 
larger segment. You might now wonder whether it is also possible to recognize a fragment that was part 
of a previously translated (larger) segment. Example:

Previously translated segment:

A dialog box will pop up. -> Es öffnet sich ein Dialogfeld.

New segment to translate:

The dialog box has to be closed.

In the above example, the term dialog box does not occur as a standalone string within a very short 
segment, but is part of a longer segment.

It is possible to recognize such segment fragments owing to a technology called ‘fine alignment’. Fine 
alignment determines which fragments in the source segment correspond to which fragments in the 
target segment. This is, of course, not always easy, as the order of the words in the target segment is often 
different from the word order in the source, as is the case in this example, i.e.:

A dialog box Es öffnet sich

will pop up. ein Dialogfeld.
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Fine alignment can identify those shifts in position, and still assign the correct source terms to their target 
equivalents to provide meaningful matches.

Preparing your TM for Fragments from Partial TUs
However, before you can use fragment matching from partial TUs, you have to configure some settings 
in your TM. Also note that the TM should have at least 5,000 TUs for the fine alignment to work. Since 
the TM that you have been using during this course is too small, we need to add another (bigger) TM for 
the next exercise:

1. Open the sample file from ..\Sample Files\Fragment matching\02 - Partial Fragment Matches.docx.

2. In the Translation Memory and Document Settings window you need to select another TM. 
The folder ..\Sample Files\Fragment matching contains a few sample TMs with more 5,000 
TUs. Click Use -> File-based Translation Memory, and select your preferred sample TM, e.g. 
English -> German.

3. Make certain that the Update check box is activated for the newly-added TM. This means 
that everything that you translate from now is going to be stored in this TM. You can 
deactivate the Update check box for the first (Training) TM to prevent the same segments 
from being stored in two TMs.
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4. Note the little warning triangle next to the TM name. It indicates that this TM is not yet 
enabled for partial TU matching. To enable it, click the Upgrade button.

5. Wait for the upgrade process to finish, then click Close.
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6. Note that the warning triangle has disappeared, which means that the TM is now enabled 
for partial TU matching.

7. Click OK again to open the document in the Editor view.

Configuring Partial TU Fragments for your Project
By default, partial TU fragment matching is not active. To activate it, take the following steps:

1. Click the Project Settings button in the ribbon.
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2. On the left-hand side of the Project Settings window, select All Language Pairs -> Translation 
Memory and Automated Translation -> Search.

3. Then select 2 as value for the options Minimum words for a match and Minimum 
significant words in a match. This means that segment fragments need to have at least two 
words to be suggested. This prevents you from getting potentially short and potentially 
useless suggestions such as house, car, etc.

4. Click OK to confirm the settings.

Using Partial TU Fragments while Translating

Now take the following steps:
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1. Start translating the first segment. Note that the term termbase comes up in another (longer) 
segment stored in the TM. Owing to fine alignment, the term has been correctly assigned to its 
target equivalent in the TM, which are both highlighted in the Fragment Matches window above the 
document.

2. You will therefore get suggestions while you are typing into the target cell. Finish translating 
the first segment, then confirm it.

3. For the following segment a whole TU fragment has been recognized. Translate segment 2, 
then confirm it.

NOTED
In the Fragment Matches window whole TU fragments are marked with the following icon:�
�

Partial TU fragments are marked with this icon:�
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4. In segment 3, a partial TU fragment has been identified. Translate this segment, and 
confirm it.

5. In segment 4 as well, a partial TU match has been found. Translate and confirm the 
segment

6. For segment 5, a number of segment fragments have been found. Note that the Fragment 
Matches window shows the highlighted source and target fragment, and the full segment in 
which it occurs. If you click the second fragment match, it will expand to show the full 
segment content. This can be useful if you want to see the context in which the fragment 
occurs.

7. Now that you have seen how partial fragment matching works, continue translating and 
confirming the current and all remaining segments, in which you should, of course, get 
numerous partial and whole TU fragment matches.
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SUMMARY

C You can retrieve entire segments as well as segment fragments from a TM.

C When a short segment stored in the TM comes up as part of larger segment, it is automatically 
suggested and can be inserted with the Enter key.

C Using a technique called ‘fine alignment’, the TM can also determine which source fragment of a 
larger segment corresponds to which fragment in the target segment. That way, the TM can also 
suggest segment fragments from partial TUs.

C For the fine alignment to work, the TM should contain at least 5,000 units. Also, you need make 
sure that partial TU fragment matching is enabled in the project settings.
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Chapter

FURTHER EXERCISES

This chapter provides a summary of the most important 
keyboard shortcuts and points to some additional sample files 
that you can use for further practice.
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IMPORTANT KEYBOARD SHORTCUTS

Below you find a list of keyboard shortcuts that are covered in this training course:

C Ctrl+Enter: Confirms the current segment and moves to the next unconfirmed segment. The 
current segment pair is stored in the TM.

C Ctrl+,: Opens a QuickPlace list to apply formatting, insert tags and placeable elements such as 
numbers and dates.

C Enter: Inserts the selected AutoSuggest hit into the target segment.

C Ctrl+Space: Removes formatting from the selected string.

C Ctrl+Shift+L: Opens a list with termbase suggestions to insert into the current target segment.

C Shift+Enter: Inserts a soft break.

C F3: Starts a concordance search for the selected string.

C Ctrl+S: Saves the current document in SDL XLIFF format.

C Ctrl+F4: Closes the current document.

MORE SAMPLE FILES

In your sample files folder we have included additional documents that you can use for further practice. 
You can find them in the ../Sample Files/Sample documents - modified sub-folder.

These documents are modified versions of the files that you have translated during this course. Therefore, 
your training TM should yield a lot of matches. Translate those files and use as much of the features that 
you have learned and the above shortcuts, e.g.:

C File analysis

C Concordance search

C AutoSuggest

C QuickPlace

C etc.



Chapter

GETTING STARTED PART 2 -
TOPICS OVERVIEW

This chapter provides a quick overview of the topics covered in 
the Getting Started Part 2 - Working with the Supply Chain and 
Pre-production training course for SDL Trados Studio.
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SDL Trados Studio Getting Started Part 2 - Topics Overview
Part 2 of the Getting Started training course covers the following topics:

C Customizing the user interface, e.g. changing the font size

C How to work in the localization supply chain: processing SDL Trados Studio and SDL WorldServer 
packages

C Delivering jobs to the supply chain through return packages

C What are context matches and perfect matches?

C Adding terminology to your termbase on the fly

C Interactive tag verification

C Adding comments to your translation

C Working with fuzzy match repair

C Downloading and installing plugins from the SDL AppStore

C Filtering for particular segments, e.g. show only segments that are untranslated

C What is SDL GroupShare?

C Creating your own AutoSuggest dictionaries

C Creating termbases from MS Excel files

C Alignment: how to leverage existing source/target documents to fill your translation memories with 
legacy content
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