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Chapter

INTRODUCTION
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ABOUT THIS TRAINING WORKBOOK

The scope of this workbook is to expand on the knowledge that you acquired in the training course SDL 
Trados Studio Getting Started Part 1. It contains practical, real-life examples of how to leverage SDL Trados 
Studio to streamline your translation processes. This document provides the following:

C Exercises that explain how you work in SDL Trados Studio- and SDL WorldServer-based supply 
chains

C An example of how to convert source and target legacy files into TM content to be used for 
upcoming translation projects (alignment)

C Instructions on how to create your own AutoSuggest dictionaries

C A sample glossary in MS Excel format to convert into a termbase

The main focus of this training guide is on practical life examples, for which training sample files are 
available.

We recommend that you copy the sample files to your Desktop, so that you can find them easily.



Chapter

USER DEFINED SETTINGS

This chapter provides some information on customization 
options, like setting your preferred language pair or specific 
fonts. for viewing your translation. 

You will learn how to:

C Customize the font size for viewing files in the editor.

C Set the default language pair, so that whenever you open 
a file for translation, the language pair is already set 
correctly.

C Select the colors used in the translation results window 
for marking differences between match from the TM and 
segment in the editor.

2
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CUSTOMIZATION

As you can customize the layout of the windows in SDL Trados Studio, you can also customize how text 
is shown in the editor or how differences between a match from the TM and the segment in the editor are 
marked.

Setting the Font Size for the Editor
1. Switch to the File tab, then click Options to access to the general settings for SDL Trados Studio.

2. This will open the Options dialog box. Select Editor and click on the small plus symbol to 
expand the list of options for the editor.
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3. Select Font Adaptation from the list to view the available settings.

4. Activate the Adapt Font sizes checkbox and select for example the minimum font size for 
text in the source column.

5. Changing the font size might become necessary, if the text in the source document is not 
readily readable with a font size of 8 point. 

6. Set the minimum font size to 12 for both the source and target language.
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7. Set the maximum font size to 18. The maximum font size is useful when the source 
document uses very large font sizes in the source text (e.g. 120 points), which would take an 
unreasonable amount of space on your screen.

Selecting your Preferred Language Pair
Select Language on the left-hand list and set the default source and target language you want to use 
whenever you translate a single document. 
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Changing the Colors in the Translation Results Window
Select Translation Results Window on the left-hand side and choose the colors that should be used to mark 
added or deleted words in the TM matches.

NOTED
If you change the setting in the Options dialog, SDL Trados Studio will remember this setting until 
you change them again, i.e. for every project you work on after customizing you settings, this settings 
will be applied.
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Chapter

PROJECT PACKAGES

This chapter provides an example of how to translate files 
contained in a project package that has been sent to you by your 
client or agency. You will learn how to:

C Open a project package

C View an analysis report

C Use active term recognition

C Add comments

C Verify tags

C Deliver a return package

3
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WHAT ARE PROJECT PACKAGES?

Project packages are created by project managers using SDL Trados Studio. Packages are compressed 
archives that contain the documents and resources required by translators, editors, proofreaders, etc. to 
complete a task, e.g.

C Source documents to translate (edit, proofread, etc.)

C Reference files

C Translation memories

C Termbases

C AutoSuggest dictionaries

Upon opening a project package the files contained therein are automatically extracted, and added to your 
SDL Trados Studio environment. The content of the package will appear as a new project in your list of 
projects. A project package file carries the extension *.sdlppx.

FOR MORE INFORMATION
V

C Overview: Working with Packages

C About Packages

OPENING A PROJECT PACKAGE

To open our sample project package take the following steps:

1. Switch to the File tab of the application ribbon.

2. Then select Open -> Open Package.

3. In the Open Package dialog box, browse to the sample files location and select the package 
file for your source/target language combination by double-clicking it, e.g. ..\Sample 
Files\Packages\Sample_Package_English-German.sdlppx.

http://producthelp.sdl.com/SDL_Trados_Studio_2015/client_en/Packages/Links-Packages.htm
http://producthelp.sdl.com/SDL_Trados_Studio_2015/client_en/projects_view/P_About_Project_Packages.htm


Pr o jec t  Packages 3

SDL TRADOS STUDIO GETTING STARTED PART 2     3-3
SDL plc Confidential. Copyright ¤�2018 SDL plc.

4. This will open the Open Package dialog box:

5. This dialog box displays, for example, project name, the due date (if any), the total and the 
untranslated number of words, the source files to translate contained in the package, etc. 

6. After taking a look at the information in this dialog box, click Finish to extract and import 
the package content. 

TIPE
The package content is usually extracted into the default project folder, i.e. C:\Users\<User 
Name>\Documents\Studio 2019\Projects. Upon extraction of the package, the application creates a 
new sub-folder that has the name of the project. If this folder already happens to exist, you will need 
to select a different folder, which must be empty.
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7. Once the import is complete, click the Close button at the bottom right corner of the Open 
Package dialog box.



Pr o jec t  Packages 3

SDL TRADOS STUDIO GETTING STARTED PART 2     3-5
SDL plc Confidential. Copyright ¤�2018 SDL plc.

8. After importing the package content SDL Trados Studio switches to the Projects view.�
The project that you have just imported from the package is shown in the Projects list.

FOR MORE INFORMATION
V

Overview: Open Package Wizard

VIEWING THE ANALYZE FILES REPORT

The sample project package contains an Analyze Files report. This report provides useful information on 
the scope of the project, e.g. the total number of words, the number of repeated segments, the number of 
segments for which matches have been found in the TM, etc.

To view the report:

http://producthelp.sdl.com/SDL_Trados_Studio_2015/client_en/ref/O-T/OpenPack/Overview_OpPWiz.htm
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1. Click the Reports button on the bottom of the Navigation pane.

2. The Analyze Files report is now displayed on the right-hand side. Take a look at the table 
with the heading Totals. This section of the report gives you an overview of all the files 
contained in the package.

Analyze Files Results
Read the Totals from bottom to top:

C The last (Total) row in the above example displays the total number of segments (22) and words 
(233). 

C The row New shows the number of segments and words for which no TM matches have been 
found.

C In the rows above New you find the number of segments and words for which fuzzy matches have 
been identified. 

C The row 100% shows the number of exact matches. 

C The row Context Match shows the number of segments for which so called context matches have 
been found in the TM. These are segments for which a 100% match has been found in the TM and 
which are preceded by the same segment as the segment from the TM. This is why context matches 
are considered even more reliable than 100% matches. 
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C Repetitions shows the number of segments for which no 100% TM match has been found, but 
which are repeated within the document(s). 

FOR MORE INFORMATION
V

Analyze Files Report Layout

VIEWING THE FILES IN THE PACKAGE

Click the Files button on the Navigation pane.

The package that you have just imported contains two files, an MS Word and an MS PowerPoint 
document, which have already been saved to the Studio-internal SDL XLIFF format.

For each file the total number of words is shown in the column Words. A Progress bar indicates whether 
a file has pre-translated content. In the above example, the MS PowerPoint document has been 22% pre-
translated by the person who sent you the package.

SELECTING A DOCUMENT FOR TRANSLATION

To start translating the document SamplePhotoPrinter.doc.sdlxliff double-click the file name. This will 
open the document in the Editor view. 

In addition to the files to translate the sample project package also contains a TM, a termbase, and an 
AutoSuggest dictionary. These databases have been automatically added to the project upon opening the 
package, and will be used when you translate the files.

Context Matches
Click inside the first segment, which will insert a translation from the TM. This time you get a so-called 
context match, which is indicated with a green CM icon in the translation status column. You can also see 
that the translation is confirmed. 

A context match is better than a 100% match. To be a context match, the translation memory segment 
must be a 100% match for the document segment and the two segments must have the same document 
context. For the document segment and the translation memory segment to have the same context, they 
must both have been preceded by the same segment.

http://producthelp.sdl.com/SDL_Trados_Studio_2015/client_en/ref/Batch_Processing/Batch_Processing___Analyze_Files.htm
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In the example a Context Match is retrieved, as the TM ’knows’ that in a previously translated document 
this segment was also found at the beginning of the document.

FOR MORE INFORMATION
V

About Translation Memory Matches

Choosing from Several TM Matches
Move down to the next segment. For this segment, a 91% fuzzy match has been found in the TM. Take a 
close look at the Translation Results window. You will notice that there are actually two possible TM 
matches, i.e. a 91% and an 86% match:

By default, SDL Trados Studio always suggests the highest match. You can switch between the TM 
matches by clicking the Select Next Match and Select Previous Match buttons. This will highlight the 
selected match in the Translation Results window and insert the corresponding target segment into the 
target cell.

http://producthelp.sdl.com/SDL_Trados_Studio_2015/client_en/About/TM/EVWorkingwithTMsAbout_Translation_Memory_Matches.htm
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Modify the selected translation to fit the current source segment, then confirm it with Ctrl+Enter to move 
to the next segment. For the next segment, the TM has suggested a high fuzzy match. Linguistically the 
suggested translation is correct, but it lacks some character formatting. Apply the required character 
formatting (bold and italics) by marking the text in the target segment that needs the formatting, pressing 
the shortcut key Ctrl+, and selecting the appropriate formatting from the QuickPlace list.

Then confirm the modified translation and move to the next segment.

Active Terminology Recognition
Some words in the source segments are highlighted with red bracketed lines to indicate that they have 
been found in the termbase (i.e. photo printer and color cartridge). Note that the termbase is part of our 
sample project package, and was deployed to your PC when you opened the package.

1. Start translating the current segment, for which no TM match has been found.

2. As soon as you start typing the first letters of the target term for photo printer, a list opens, 
and suggests possible translations, e.g. Fotodrucker for photo printer.�

In the above example the same translation is suggested from the AutoSuggest dictionary 
(the suggestion marked by the green/yellow icon) and from the termbase (the suggestion 
marked by the gray icon).

3. You can click any of the suggestions to insert the target term into your translation.
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4. You may also use another way of inserting the target terms from the termbase: the second 
recognized term in the current segment is color cartridge. To insert the target term into your 
translation use the shortcut key combination Ctrl+Shift+L.

5. This will open a list with all termbase suggestions (and only termbase suggestions) relevant 
for the current segment. Click the target term for color cartridge in the list (i.e. Farbpatrone) to 
insert it into your translation.

FOR MORE INFORMATION
V

C Term Recognition Window

C Working with Termbases

http://producthelp.sdl.com/SDL_Trados_Studio_2015/client_en/screen_layout/Editor_View/TermRecWin.htm
http://producthelp.sdl.com/SDL_Trados_Studio_2015/client_en/edit_view/Terms/EVWorkingwithTerminologyOverview.htm
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Displaying the Full Termbase Entry
Sometimes it can be useful to view the entire termbase entry rather than only the source and target term. 
To do this take the following steps:

1. In the Term Recognition window select one of the displayed source or target terms.

2. Right-click the selected term and select View term details from the context menu.

3. This will slide in the Termbase Viewer window, which displays the full entry and an 
alphabetically sorted list of some other terms on the left-hand side.
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4. A termbase entry can contain a lot more information than just the terms in the different 
languages. Click the term ContraPLUS to view the full entry content.

5. This is an example of a termbase entry that includes additional information such as 
definitions, graphics, etc. 

6. Move the mouse pointer out of the Termbase Viewer window, which will cause it to hide 
automatically.

Adding Terms on the Fly
Besides inserting terms from the termbase into your target segments, you can also add new terms from 
the document to the termbase. Example: the word paper has not been found in the termbase. To add it to 
the termbase, take the following steps:

1. Highlight the word paper in the source segment by double-clicking it.

2. Highlight its equivalent in the target segment (e.g. Papier).

3. While both words are highlighted click the right mouse button on one of the highlighted 
terms.

4. Select Add New Term from the context menu.
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5. A draft entry is now displayed in the Termbase Viewer window. Click the Save this Entry 
button to save the new entry in the termbase.

Move the mouse pointer out of the Termbase Viewer window, which will cause it to auto-hide. Confirm 
the finished target segment with Ctrl+Enter. When you move to the following segment note that the term 
paper is now highlighted with a red bracketed line. This means that you can click the shortcut key 
combination Ctrl+Shift+L to open a list of available target terms, among which you will find the translation 
for the newly-added term paper.

FOR MORE INFORMATION
V

How to Add Terms to a Termbase

http://producthelp.sdl.com/SDL_Trados_Studio_2015/client_en/edit_view/Terms/EVTermbaseActionsAdd_Terms_to_a_Termbase.htm
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Inserting Tags
Now we translate segment number 5, for which there is no TM match. It contains a string enclosed in a 
bookmark start and end tag pair.

To insert the tags using the keyboard, take the following steps:

1. For this exercise it is useful to display the full tag text. To do this click the Full Tag Text button on the 
View tab. Afterwards, go back to the Home tab.

2. Start translating the segment and stop just before you translate the English word clearance, 
which is enclosed in bookmark start/end tags.

3. Press the Ctrl+, on your keyboard. This opens a list of possible tags to place at the current 
cursor position. 

4. Select the entry <bookmarkstart name=“clearance“/> from the list.

5. Type the target equivalent for clearance, press Ctrl+, again and select the <bookmarkend 
name=“clearance“/> tag from the list to insert the second tag into your translation by 
pressing the Enter key.

6. Finish translating the segment and confirm it with Ctrl+Enter to continue.

Interactive Tag Verification
The next segment also contains a bookmark start/end tag pair:

Intentionally leave out both tags, and confirm with Ctrl+Enter to see what happens.

As soon as you confirm the translation a red Error icon will be displayed between the source and target 
segment. 
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Move the mouse pointer over the icon. This will display the reason for the error in a tooltip. In the above 
example, you are being warned that you left out both bookmark tags.

Go back to the segment (e.g. with the Up Arrow key on your keyboard) and insert the tags using the Ctrl+, 
keyboard shortcut. Then confirm the segment again.

The interactive tag verification is triggered when you confirm a segment. How does SDL Trados Studio 
react when you neglect to insert tags, and you do not confirm the segment? Give it a try with the next 
segment, which contains a field tag:

Translate the segment without inserting the tag. Then move to the following segment without confirming 
it, i.e. simply use the Down key to continue. Observe that although you left out the tag, no warning icon 
appears when moving to the next segment, i.e. the interactive tag verification is only triggered when you 
confirm a translation. 

You can also run a tag verification on the entire document, i.e. also on unconfirmed segments. We will 
have a look at this type of verification later, when you have finished translating the document.

For now, translate and confirm the next segment, which consists of a single word (i.e. ventilation). Then 
go to the following segment (Connecting and turning on the power).

FOR MORE INFORMATION
V

Tag Verification

Adding Comments
You can add comments to particular segments or expressions/words in your translation (not to the source 
language segments). This is useful e.g. when you want to:

C Flag a translation that you need to check on later

C Provide information for the reviewer, proofread, project manager, etc.

To add a comment, take the following steps: 

1. Translate segment 9, i.e. Connecting and turning on the power.

2. Select a word in your translation, e.g. by double-clicking it.

http://producthelp.sdl.com/SDL_Trados_Studio_2015/client_en/FileTypes/Verifying_Tags.html
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3. Right-click the highlighted word. From the context menu select Add Comment.

4. In the text area of the Add Comment dialog box enter the comment text, e.g. Ask Dave 
whether this is correct. Then click OK.

5. After adding the comment the selected word is highlighted. When you move the mouse 
pointer over the highlighted string, the comment text (including the name of the user who 
added the comment as well as the date/time) is displayed in a tooltip.

Confirm the segment with Ctrl+Enter, and continue translating the following segments. Let us add 
another comment, this time not to a particular string, but to the segment as a whole:

1. After translating the segment, make sure that no particular word is selected.
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2. Right-click anywhere inside the segment and select Add Comment from the context menu.

3. Enter the comment text into the Add Comment dialog box, then click OK.

4. This time the whole segment content is highlighted.

You can also edit existing comments by right-clicking the commented expression/word or segment. Select 
Edit Comment from the context menu. In the Edit Comment dialog box click Edit to edit an existing 
comment text. With Add you can add another comment to the same segment or expression/word.

TIPE
If a comment applies to the whole document rather than to a particular string or segment, select 
Current File from the Scope dropdown list before adding the comment.

Commented segments and expression/words are highlighted and therefore easy to spot. However, if you 
want to see all comments in a document (or several open documents), click the Comments tab.

For each comment you will see the comment text, the name of the document the comment was found in, 
the date/time, etc.

C Edit Comments

C Comments Window

http://producthelp.sdl.com/SDL_Trados_Studio_2015/client_en/screen_layout/Editor_View/Comments_Window.htm
http://producthelp.sdl.com/SDL_Trados_Studio_2015/client_en/edit_view/Comments/Edit_Comments.htm
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Copy Source to Target
Continue translating the remaining segments, i.e. segments 12 - 21. The last segment (21) says: �
•  2009 SDL International. This segment actually does not need to be translated. It can be pasted into the 
target cell. Rather than relying on the Windows clipboard (i.e. copy/paste), you can use the Copy Source 
to Target button located at the top of the Translation Results window. 

Click this button to duplicate the source segment into the target cell. (The default keyboard shortcut is 
Ctrl+Ins.) Then confirm the segment with Ctrl+Enter.

The Copy Source to Target function is highly useful for target segments that are identical or very similar 
to their source-language counterparts, e.g. sentences that contain a lot of untranslatable product names.

Display Filtering
Suppose you have finished translating the entire document, and you would like to take a particular look at 
all segments that have comments. To show only specific segments, take the following steps:

1. Switch to the Review tab of the application ribbon.

2. By default, the display filter is set to display all segments. Click All segments (i.e. the filter 
button) to show the numerous display options.
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3. From the available options select Segment Review -> With comments.

4. The Editor now displays only segments with comments, regardless of whether the 
comments were added to a selection or to the whole segment. This is useful, for example, if 
you want to focus on the commented segments during proofreading. 

5. Note that the status bar on the bottom of the application also shows the currently selected 
display filter option. Even when the Review tab of the ribbon is not selected, you can 
ascertain at a glance which display filter is currently active. Clicking the display filter option 
in the status bar opens the display filter list and switches to the Review tab.

When you have checked on a commented segment and found it to be correct, you will certainly want to 
delete the comment:

1. Select the comment to delete in the Comments window.
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2. Click the Delete Comment button.

3. This removes the comment from the list and, of course, also from the corresponding 
segment.

To display all segments again, go to the display filter dropdown list (on the Review tab) and select General 
-> All segments. Make sure all segments in the current document are translated and confirmed. Save the 
document with Ctrl+S.

NOTED
Comments that were added to a document rather than a word/phrase or segment can only be viewed 
in the comments window.

FOR MORE INFORMATION
V

About Filtering Segments

Running Tag Verification on the Whole Document
After translating a document you should run a tag verification on the entire text. To start a tag verification 
on the entire document take the following steps:

1. In the Review tab click the Verify button (or press F8).

2. If tag errors are found, they will be listed in the Messages window, which will be displayed 
instead of Translation Results.�
In the above example a missing field tag has caused an Error message. 

3. Double-click the message to jump to the segment in which the problem has been found.

NOTED
There are three different message types: �
Errors (red) are serious problems, which can in a worst-case scenario even prevent you from saving 
the translation back in its native format. �

http://producthelp.sdl.com/SDL_Trados_Studio_2015/client_en/edit_view/EV_About_Filtering_Segments.htm
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Warnings (yellow) point to problems that might, for example, lead to a loss of formatting, 
bookmarks, etc., however, that usually do not prevent you from saving the translation in its native 
format. �
Notes (white) usually point to cosmetic issues such as missing spaces around tags.

4. Insert the missing tag into the highlighted segment, and confirm it with Ctrl+Enter, which 
will remove the Error message from the list. 

5. Save the file again. For this you can also use the keyboard shortcut Ctrl+S.

FOR MORE INFORMATION
V

Messages Window

Selecting the Second File in the Package
Remember that the project packages also contains a small MS PowerPoint file. To switch to the second 
document take the following steps:

1. Click the Files View button in the Navigation pane.

2. Note that in the file list the progress for the Microsoft Word document is at 100%, (provided 
that you translated and confirmed all segments). Double-click the file 
SamplePresentation.ppt.sdlxliff to open it in the Editor view.

The sample presentation is very easy to translate, as it contains only two segments, which are both context 
matches. This is because they occur in exactly the same order in the Microsoft Word document that you 
previously translated.

http://producthelp.sdl.com/SDL_Trados_Studio_2015/client_en/screen_layout/Editor_View/Messages_Window.htm
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Note that as you did not close the previous document, its name is still being shown in a tab in the Editor 
view. You can quickly switch back to the first document by clicking the corresponding tab.

In SDL Trados Studio you can have several documents open at the same time. This can be useful, for 
example, if you want to quickly check on the translation in a previous document.

Save the sample presentation by pressing Ctrl+S.
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CREATING AND SENDING THE RETURN PACKAGE

After finishing the translation you send back the package to the project manager (or customer) in the form 
of a return package. Return packages (like project packages) are compressed archives that contain the 
translated, edited, or proofread documents. To create the return package, take the following steps:

1. Click the Projects View button to open the Projects view.

2. Right-click the PhotoPrinter Manual project and select Create Return Package from the 
context menu.
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3. The Progress bars in the Create Return Package dialog box show the translation progress for 
each file. They should be at 100%. Click Next to continue.
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4. Click Browse and select the location for the return package and the file name. Enter 
Photo_Printer_target.sdlprx as return package name. Note that return packages have the 
extension *.sdlrpx, which is added automatically to the file name. In the Comment text field 
you can enter an optional message for the recipient of the package (i.e. the customer or 
project manager).

5. When the return package has been created you can send the return package by clicking the 
Send Package by Email button.
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6. This will automatically create an email using Microsoft Outlook (if available), and add the 
return package as an attachment.

7. You can also choose to click the Open Target Folder button. This will launch Windows 
Explorer, where you can view the file, attach it to an email, upload it to an FTP server, etc.

8. Last, click Close to close the Create Return Package dialog box.

FOR MORE INFORMATION
V

C How to Return Completed Work in a Return Package

C Create Return Package Wizard > Creating Return Package

http://producthelp.sdl.com/SDL_Trados_Studio_2015/client_en/Packages/About_Creating_Return_Packages.htm
http://producthelp.sdl.com/SDL_Trados_Studio_2015/client_en/Packages/P_Create_a_Return_Package.htm
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Marking the Project as Complete
Make sure that you are still in the Project view. Note that the project, which you initially imported from 
the project package, is still shown as In Progress in the Status column.

For good measure, mark the project as complete. When you are dealing with multiple projects this will 
help you see at a glance which projects are completed, and which ones are still in progress.

1. Right-click the project name in the Projects view, and select Mark as Complete from the context 
menu.

2. Confirm by clicking Yes.

Note that the Status column now shows Completed for the sample project.

SUMMARY

C Project packages contain the translatable files, project translation memories and possibly further 
elements such as reference files, termbases, etc.

C When opening a project package in Studio the package content needs to be extracted to an empty 
folder.

C The project package contains a file analysis reports, which gives an overview of the total number of 
words, the repetition and the TM leverage rate, etc.

C You can view the translatable project files in the Files view. From there you can open the files for 
translation by double-clicking them.

C After finishing the translation you create a return package, which contains the translated files, and 
which can then, for example, be e-mailed to the customer/project manager.
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Chapter

SDL WORLDSERVER PACKAGES

This chapter contains an example of how to process project 
packages that come from SDL WorldServer. You will learn how 
to:

C Open an SDL WorldServer package

C Handle locked segments and PerfectMatches

C Create a Work in Progress (WIP) report

C Create the return package for delivery to SDL 
WorldServer

4
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WHAT IS SDL WORLDSERVER?

SDL WorldServer is a sophisticated online workflow management system. It can generate project 
packages, which are similar to the packages that you have seen in the previous chapter. SDL WorldServer 
packages can be downloaded through your Web browser. After opening and translating the package 
content with SDL Trados Studio, you can create a return package and upload it to SDL WorldServer.

In this chapter you will see how to open a sample package, which has downloaded from SDL WorldServer. 
The process of opening the package is identical to opening SDL Trados Studio packages (see previous 
chapter).

Opening the SDL WorldServer Package
To open our sample SDL WorldServer package take the following steps:

1. Switch to the File tab of the application ribbon.

2. Then select Open -> Open Package.

3. In the Open Package dialog box, browse to the folder that contains the sample packages, i.e. 
..\Sample Files\Packages.

4. If you prefer to open a sample package that goes from English into German, then select the 
file tasks_Sample_WorldServer_Project_1037_de_DE_xliff. For English into French, select 
tasks_Sample_WorldServer_Project_1038_fr_FR_xliff.
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5. This opens the Open Package wizard. Click Next to continue.

6. Wait until the package has been prepared for import, and then click Next again.
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7. The following screen shows an overview of the package content, e.g. the total numbers of 
words, the files and their respective progress, etc. Click Finish to unpack the project files.

NOTED
The package content is usually extracted into the default project folder, i.e. C:\Users\<User 
Name>\Documents\Studio 2019\Projects. Upon extraction of the package, the application creates a 
new sub-folder that has the name of the project. If this folder already happens to exist, you will need 
to select a different folder, which must be empty.
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8. Once the import is complete, click the Close button at the bottom right corner of the Open 
Package dialog box.

9. After importing the package content SDL Trados Studio switches to the Projects view.�
The project that you have just imported from the package is shown in the Projects list.

Translating the Package Files
Double-click the project name to switch to the Files view. Here, you double-click the file 
sample2129241384607501759.sdlxliff (i.e. the file with the MS Word icon) to open it in the Editor.

NOTED
Names of files have been downloaded from SDL WorldServer typically contain a sequence of 
numbers. This ensures uniqueness of all files in the SDL WorldServer system.

PerfectMatch Segments

The sample file will look as shown below:
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Note that segments 1 through 3 are marked with a PM icon, which stands for PerfectMatch. PM matches 
are considered highly reliable (even more reliable than context matches), as PerfectMatch takes the context 
of a segment into consideration even more than CM matches. For this reason, they are often locked, i.e. 
they usually are not supposed to be edited.

However, let us assume that you would like to make a change in segment 3, for example, you would like 
to exchange the word weiteres with anderes. Take the following steps:

1. Try to edit target segment 3 accordingly. Note that this is not possible, and a popup message will 
inform you that the current segment is locked.

2. However, you can unlock this segment by clicking the Lock Segment - > Unlock segments 
command on the Advanced tab. Note that the yellow lock icon has disappeared, and that the 
segment text is no longer grayed out. The segment is now available for editing.

3. Edit the segment as required, and then confirm it.

4. To restore the lock for the edited segment, click inside segment 3, then click the Lock 
Segment -> Lock Segments command. Note that the yellow lock icon has re-appeared next to 
the segment and that the segment text is grayed out.

TIPE
You can also unlock and lock segments by pressing Ctrl+L.

Handling Tags
Continue by translating and confirming 4 and 5. Note that after confirming segment 5, segments 6 and 7 
are skipped, as they are already confirmed. Now translate segments 8 through 11. This is mostly a revision 
exercise from the Getting Started Part 1 training course.

The sample document contains a few tags, which you should handle as outlined below:
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1. Note that segment 12 contains one placeholder tag, which has already been inserted into the target 
cell. Files that are pre-processed in SDL WorldServer typically have all tags pre-inserted into the 
target segment if no match has been found, as is the case for segment 12.

2. When you get inside segment 12, a translation suggestion will be inserted, and the tag will 
be removed. The reason for this is the fact that you have already translated this segment 
before, but without the tag. Consequently, a 99% fuzzy match will be automatically inserted.

3. However, you still need to decide where the tag needs to be placed in the target segment. 
This is not done automatically, as the position of the tag can be different in the target 
language. Use Ctrl+, (i.e. QuickPlace), to insert the tag where it is required to be, and then 
confirm the segment.

4. Continue by translating and confirming segment 13.

5. Segment 14 contains a number of tags. Here, it turns out quite useful that SDL WorldServer 
has populated empty target cells with the tags. All you need to do is to enter your translation 
between the tags.

6. Confirm segments 14 and 15.

Finally, you can save the document (by pressing Ctrl+S) and close it (by pressing Ctrl+F4).

Work in Progress (WIP) Report
After closing the document you should be back in the Files view. Being in the middle of the project, you 
may now want to get an overview of how much work still has to be done, e.g. how many segments still 
need to be translated or reviewed. For this, you can create a so-called WIP (Work in Progress) report. This 
report gives you a concrete idea of the work that still has to be done. For example, untranslated segments 
remain to be translated, draft segments need to be edited, translated segments usually need to be reviewed, 
etc. To create a WIP report for the current project, take the following steps:
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1. Make sure that both files in the package are selected, then click Batch Tasks -> WIP Report.

2. On the first screen of the Batch Processing wizard, click Next.

3. The Settings page lists the confirmation levels, match types, and the required type of work. 
For example, untranslated segments require translation (of course), while translated 
segments require review, and locked segments do not require any type of work. Just take a 
look at these settings, as they cannot be changed anyway. Then click Finish.
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4. When the report creation has finished, click Close.

5. In the Navigation pane click Reports to switch to the Reports view.

6. Make sure WIP Report under Multiple Languages is selected. This will display the WIP 
report. Scroll down to the section Total in order to view the WIP statistics for the whole 
project. As you can see, 13 segments remain to be translated, while 10 translated segments 
require review.

7. Let us assume that you are not the one doing the review. Your job is just to finish the 
translation. Therefore, switch back to the Files view, and double-click the file 
sample_answering_machine8320977215196477423.sdlxliff to open it in the Editor.

Translate the second document, which also contains a number of PerfectMatches. Again, this is largely a 
revision exercise, and you can use all the features that you learned in the Getting Started Part 1 training 
course.

Creating the Return Package
After having saved and closed the second sample files, you should be back in the Files view. As both files 
have been fully translated, you will want to deliver them back to SDL WorldServer. To do this take the 
following steps:

1. Select both files, and then click the right mouse button.

2. Select Create Return Package from the context menu.

3. On the first screen of the Create Return Package wizard click Next.

4. There are two ways of delivering your translated files to SDL WorldServer:

C The translations are either uploaded directly to SDL WorldServer from SDL Trados Studio, if 
you have a live connection, or ...

C You create a return package file, which you then upload later to SDL WorldServer through the 
Web browser.
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5. Let us assume that for the moment we have no live connection to SDL WorldServer. 
Therefore, we go for the latter option, and create a return package (like we did for the SDL 
Trados Studio package in the previous chapter). To do this click the File radio button. This 
enables the corresponding text field in which you see the return package file path and name.

NOTED
In this training course, we are using a generic package with no live connection to an SLD WorldServer 
system. In a real-life scenario, the address of the corresponding SDL WorldServer would be visible in 
the Server field, and you could upload your translation directly.

6. SDL Trados Studio creates the packages at a default location, i.e. at 
C:\Users\<UserName>\Documents\Studio 2019\Projects. Click Finish to create the return 
package.

7. After the package has been created click Close.

Open the folder in which the return package has been stored in Windows Explorer, i.e. 
C:\Users\<UserName>\Documents\Studio 2019\Projects.

There you will find the package file to upload to SDL WorldServer.

TIPE
The suggested return package names can also be changed.

SUMMARY

C SDL WorldServer creates project packages, which are very similar to the SDL Trados Studio project 
packages, and which can be opened in exactly the same way.

C Files that have been processed in SDL WorldServer can also be translated the same way as files that 
have been directly opened in SDL Trados Studio. The only difference is that SDL WorldServer 
automatically copies any tags into the target cells if no TM match has been found for a particular 
segment.



SDL Wor ldServer  Packages 4

SDL TRADOS STUDIO GETTING STARTED PART 2     4-11
SDL plc Confidential. Copyright ¤�2018 SDL plc.

C To deliver your translations you can either create a return package or upload directly to SDL 
WorldServer, if a live connection is available. Otherwise, you need to manually upload the return 
package to SDL WorldServer using the Web browser.

C PerfectMatches are considered highly reliable translation suggestions, as they fit the current 
context.

C You cannot edit locked segments unless you unlock the with the keyboard shortcut Ctrl+L or the 
corresponding button.
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Chapter

ALIGNING LEGACY FILES

This chapter provides an example of how to align source 
documents with their existing translations. An alignment 
allows you to import translated legacy content into a translation 
memory for use in future translation projects. You will learn 
how to:

C Align a single file pair

C Review and edit the alignment result

C Import the alignment result into a translation memory

C Align multiple file pairs

5
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WHAT IS ALIGNMENT?

Alignment is a process that allows you import existing translations into a TM. Imagine that you have an 
English source file and the corresponding target document, but the content is not stored in a translation 
memory database, as the translation was done without a TM system. Alignment allows you to pre-process 
both the source and the target file(s), so that you can import the legacy content into a TM.

The main challenge during alignment is to determine whether segments or entire paragraphs were left 
out during translation. Sometimes content is left out, because it is not relevant for the target audience. 
Also, translators often change the segmentation, e.g. by translating two source segments with just one 
target segment. SDL Trados Studio uses a sophisticated algorithm to detect such discrepancies between 
the source and the target content.

The exercises in this chapter involve two scenarios in which English source documents needs to be aligned 
with their translations. The sample files for this exercise can be found in your sample files folder, i.e. 
..\Sample Files\Alignment.

ALIGNING A SINGLE FILE PAIR

In the first exercise we are going to align an English legacy source file with its translation.

To set up the alignment project take the following steps:

1. On the Welcome screen of SDL Trados Studio select Align Documents -> Align Single File Pair.
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2. This opens the Align Documents page.

Creating a new Translation Memory
Let us assume that you would like to import the alignment result into a new TM. Therefore, set up an 
empty TM by taking the following steps:

1. Click the Create button, and select New File-based Translation Memory.
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2. This will open the New Translation Memory wizard. Enter the name for your TM into the 
Name text field, e.g. Alignment TM En-De. Note that the sample files to align are English to 
German. Make certain that the correct source and target language pair is selected.

TIPE
The TM file will be stored at the path that is shown in the Location text field. You may change the TM 
location by clicking Browse and selecting another path.

3. Click Next to continue. This will lead you to the Fields and Settings page. It is possible to 
store additional meta information in a TM. For example, for each segment pair you can store 
the name of the project that it relates to, the customer name, etc. Let us assume that you 
would like to add the name of the project to each segment pair that will later be imported 
from the alignment into the new TM.
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4. To enable your new TM to store the project name, click into the empty field under Name and 
enter the field name, i.e. Project.



Al ign ing  Legacy  F i l es5

5-6    SDL TRADOS STUDIO GETTING STARTED PART 2
SDL plc Confidential. Copyright ¤�2018 SDL plc

5. Fields can be of different types, e.g. free text fields, list fields, etc. Let us assume that the 
project name should be a free text field. Click into the empty field under Type and select the 
option Text.
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6. To create the TM click Finish, then Close. The TM name and path is now shown in the Align 
Documents window.

Adding the Documents to Align
To select the file pair take the following steps:

1. Click the Browse button below the Source File text field and select the English sample file, i.e. 
..\Sample Files\Alignment\English.docx.
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2. Repeat the above step for the target file, i.e. ..\Sample Files\Alignment\German.docx.

3. Click Finish to start the alignment.
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Viewing the Alignment Result

After a few seconds you will find yourself in the Alignment view, which shows the alignment result in a 
side-by-side view:

The column on the left-hand side shows the source segments, the column on the right-hand side lists the 
corresponding target segments. The column between source and target segment visualizes the 
connections that have been made between source and target content during the alignment process.

You might have noticed that some segment pairs are connected using a green dotted line, while others 
show a yellow or red line. The colors indicate how reliable a particular segment pair is considered to be by 
the alignment algorithm.

Move the mouse pointer over the id (i.e. 2) of the second segment pair, which has a green line. A tooltip 
shows that this particular alignment pair is considered to be of good quality with a trust score of 92.



Al ign ing  Legacy  F i l es5

5-10    SDL TRADOS STUDIO GETTING STARTED PART 2
SDL plc Confidential. Copyright ¤�2018 SDL plc

If you move your mouse pointer over the id of source segment 10, which is connected to target segment 
9 with a yellow line, you will see that this segment pair is considered of average alignment quality with a 
trust score of 90.

Source segment number 11, which is connected to target segment 10 using a red line, is even considered 
of low alignment quality with a trust score of only 50.

NOTED
Alignments of average or low quality are not necessarily incorrect. The dotted line color and the trust 
score are just indications of how reliable the alignment algorithm is considering a particular segment 
pair alignment to be.

Confirming Segment Pairs

All segment pairs are by default unconfirmed. When you review an alignment result, you can confirm the 
segment pairs and re-connect segments if required.

To confirm segment pairs that are correct, take the following steps:

1. As you can see, the first segment pair has been aligned correctly. Therefore, click the Confirm 
button or press Ctrl+Shift+F.

2. Note that after confirming the first segment pair, a full green line is drawn between the 
source and the target segment. Also, the tooltip shows that the segment pair is confirmed 
with a trust score of 100.

3. Use the Arrow Down key to move to the second segment pair, which you confirm as well. 
Repeat this procedure for segments 3 through 5.
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Editing Segments
You can edit the content of source and target segments if necessary. Let us assume that in segment 6 you 
would like to replace Preparing Microsoft Word with Setting Up Microsoft Word. All you have to do is 
overwrite the source text as required. Make the corresponding change in the target cell, then confirm the 
segment pair by pressing Ctrl+Shift+F.

n:n Alignments
Up to this point you have only had clean 1:1 alignments. However, different segmentation between source 
and target segments can also lead to, for example, 2:1 alignments, which is the case for source segments 
7 and 8, which have both been linked to target segment 7.

In this case, the 2:1 alignment is correct, and you can therefore confirm it. You can also confirm source 
segments 9 through 24, as these are all correct alignments.

Correcting Misalignments
It can also happen that segment pairs are not correctly aligned. This is the case, for example, for source 
segment 27. Click inside source segment 25, which will highlight the target segments to which it has been 
linked, i.e. 26 and 27. As you can see, the alignment is not entirely correct here. Actually, source segment 
27 should be linked only to target segment 26.
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This misalignment has caused a subsequent problem: Source segment 28 has been linked to target 
segment 28. However, it should have been linked to target segments 27 and 28. From segment 29 
onwards, the alignment is correct again.

NOTED
Misalignments can lead to consecutive faults, but usually these remain limited to a specific part of 
the text. I.e. a single misalignment does not have an impact on the entire rest of the document.

To correct the misalignments take the following steps:

1. Make sure that you are inside source segment 25, then click the Disconnect button or press 
Ctrl+Alt+D.

2. Note that this has removed the connections between source segment 27 and target segments 
26 and 27.

3. Disconnect source segment 28 in the same way.
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4. Now click the Alignment Edit Mode button.

5. Observe that in the alignment edit mode you find check boxes next to each segment. Check 
the box for source segment 27 and for target segment 26.

6. All of the above segment pairs require simple 1:1 alignments. Therefore click the Connect 1:1 
button.

7. Note that this has turned the checked segment pair into a confirmed alignment.

8. Observe that source segment 28 needs to be connected to target segments 27 and 28 
through a 1:2 alignment. Therefore, make sure that the corresponding check boxes are 
selected.
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9. To establish the 1:2 connection click the Connect n:n button.

10. Click the Alignment Edit Mode button once more to deactivate the alignment edit mode. 
Note that the 1:2 connection has been confirmed between source segment 28 and target 
segments 27 and 28.

11. Confirm all remaining segment pairs, which are aligned correctly.

Saving the Alignment Result
To save your work take the following steps:

1. Click Save -> Save in the application ribbon.

2. You will now be prompted to save the alignment result as an *.sdlalign file. Click Save to 
confirm.

Importing the Alignment Result into the Selected TM
To import the alignment result into your translation memory take the following steps:

1. In the application ribbon select Import into Translation Memory -> Advanced Import.

NOTED
The Quick Import option will import the alignment result directly into the TM with a single click. The 
Advanced Import allows you to set a number of options before the import is performed.
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2. On the first page of the Translation Memory Import wizard click Next.

3. You will now see a few import settings that you can configure. One example is the 
Alignment quality value, which is by default set to 0. If you want to have only confirmed 
segment pairs to be imported into your TM, you should set this value to 100. If you want to 
have segment pairs with an average or low trust score to be imported, then select a value 
lower than 100. For this exercise let us keep the alignment quality value unchanged.
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4. Remember that we have set up our TM with a Project text field. Let us assume that you would 
like each segment pair to feature the name of the project that the aligned documents belong 
to, e.g. Alignment Sample. To make sure that this piece of meta information is added to the 
imported segment pairs, click the Edit button, which will open the Field Values dialog box.
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5. Click inside the empty field below Value, and enter Alignment Sample. Then confirm with 
OK.

6. Finally, click Finish to start the import. After a few seconds a message box appears to inform 
you how many segment pairs have been added to your TM. Click OK to close the message 
box.

Viewing the TM Content
To view the TM content take the following steps:

1. Click the Translation Memories View button in the Navigation pane to switch to the Translation 
Memories view.

2. Click the Open button in the application ribbon.
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3. Browse to the location where you created your TM, and select the TM file by double-clicking 
it.

4. The TM content (i.e. the alignment result) is now displayed as shown below:

The segment pairs are shown in a side-by-side view. Take a look at the column on the right-hand side. This 
column contains the meta information that has been added to each imported translation unit, i.e.: the 
alignment document name, and the Project field value.

ALIGNING MULTIPLE FILE PAIRS

In addition to aligning one source with one target file, you can also align multiple files at the same time. 
These files can also be stored in various sub-folders. To do this take the following steps:

1. Switch to the Welcome screen, and select Align Documents -> Align Multiple Files from the 
application ribbon.
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2. On the first page of the Align Documents wizard click Add -> File-based Translation 
Memory.

3. Browse for the TM that you created in the previous section when you aligned the single 
document pair, and select it by double-clicking the TM file.

NOTED
The alignment results will be stored in a folder, e.g. ..\Studio 2019\Alignment Results. You may select a 
different folder by clicking the Browse for folder button.

4. Click Next to continue.
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1. Click the Add button, then select Source Files by Folder.

2. Browse to your sample files location and select the folder ..\Sample Files\Alignment\English.
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3. Now select the target folder by clicking the Add button, then select Target Files by Folder.

4. Browse to your sample files location and select the folder ..\Sample Files\Alignment\German.
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5. The source and target folders contain various sub-folders. Drill down to 
..\English\Desktop\Common. This will reveal the corresponding source and target files.

NOTED
The source and target files do not necessarily have to have identical names for the alignment to work.

6. Click Finish to start the alignment process.
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7. Wait until all documents have been processed, then click Close.

8. You will now be prompted whether to open the folder that contains the alignment result 
files. Choose Yes.

9. This will open the folder that contains the alignment results in the form of *.sdlalign files. 
For each aligned file pair a bilingual *.sdlalign file has been created, which contains the 
actual alignment result.

NOTED
You could review each alignment result in Studio, by double-clicking the corresponding *.sdlalign file, 
and then confirm and modify the results as required. However, to keep this exercise simple, let us 
assume that this time we want to import all alignment result files without reviewing them.
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Importing the Alignment Result into the TM
To import all alignment result files into the TM take the following steps:

1. Click the Translation Memories View button in the Navigation pane to switch to the Translation 
Memories view.

2. The TM from the previous exercise should still be open. Click the Import button in the 
application ribbon.
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3. In the Import window click Add Folder, and select that folder that contains your alignment 
result. All *.sdlalign files will then be listed under Files.

4. Now click the Next button. 

5. The following pages display a number of advanced options, which we leave unchanged. 
Therefore, just click Next twice to continue.

6. On the last page of the import wizard click Finish to start the import.

7. Wait a few seconds for the import to finish, then click Close.

Browsing the TM Content
You should now see the content of your TM. Note that all segment pairs are sorted chronologically, i.e. the 
units that were first imported are shown first. By default only 50 segment pairs are displayed on one page. 
To navigate to the next 50 units take the following steps:

1. Make sure that the Home tab of the application ribbon is selected. Then click the Next Page button.�

2. This shows the next 50 segment pairs. Click the Next Page button two or three more times to 
browse further in your TM.

3. To move back to the previous page click the Previous Page button.
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4. Now move back to the first page by clicking the First Page button.�
�

Viewing the TU Count
To ascertain how many segment pairs have been imported in your TM, right-click the TM name, then 
select Settings from the context menu.

On the bottom of the Translation Memory Settings dialog box you can see the number of translation units:
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Click OK to close the dialog box.

SUMMARY

C SDL Trados Studio offers an alignment feature through which you can import the content of legacy 
source and target documents into a translation memory.

C You can add single file pairs as well as folder structures that contain multiple source and target 
documents.

C You can review the alignment result to correct any misalignments. During review you can confirm, 
disconnect, and reconnect segment pairs, and edit the source and target content.

C Studio uses different colors (green, yellow and red) to visualize whether a particular segment pair 
alignment is considered of good, average or low quality.

C The alignment supports one-to-one as well as one-to-many connections for cases in which, for 
example, one source segment has been translated with two target segments.

C After reviewing the alignment result you can import it into the selected TM. When importing you 
can choose to apply TM field values, import the alignment result as plain text, set the alignment 
quality value, etc.

C You can also import the alignment result (i.e. the *.sdlalign files) directly into the TM without 
reviewing it.
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Chapter

GENERATING AUTOSUGGEST 
DICTIONARIES

In this chapter you will learn how to:

C Create an AutoSuggest dictionary from a TM export file 
in TMX format

6



Genera t ing  AutoSugges t  D ic t ionar i es6

6-2     SDL TRADOS STUDIO GETTING STARTED PART 2
SDL plc Confidential. Copyright ¤�2018 SDL plc.

GENERATING AN AUTOSUGGEST DICTIONARY

AutoSuggest dictionaries offer for segment fragment matching for increasing translation productivity. 
AutoSuggest dictionaries intelligently suggest segment fragments that fit the current context while you 
are typing.

AutoSuggest dictionaries are created from existing translation memories. The TM input files can be in one 
of the following formats:

C *.sdltm

C *.tmx (Translation Memory Exchange)

C *.tmx.gz (compressed TMX format)

For this exercise we provide a TMX sample file, which you can find in your sample files folder. i.e. 
..\Sample Files\Generating AutoSuggest Dictionaries.

To create an AutoSuggest dictionary from an existing TMX file, take the following steps:

FREELANCE
T

AutoSuggest dictionaries can only be created with the SDL Trados Studio Professional or the 
Freelance Edition with the AutoSuggest dictionary creator add-on. If you have the Freelance Edition 
without the add-on, you can use AutoSuggest dictionaries, but you can only create them within the 
first 30 days after installation of the product.

1. Switch to the Welcome view.

2. Make sure that the Home tab is selected. Then click the Create AutoSuggest Dictionary 
button.
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3. This opens the New AutoSuggest Dictionary dialog box. Here, click the Browse button to 
select the TMX input file.

4. In the Open File-based Translation Memory dialog box, make sure that the file type TMX 
Translation Memories (*.tmx;*.tmx.gz) is selected in the file type dropdown list.�

5. Browse for the sample TMX file from which the AutoSuggest dictionary is to be created, i.e. 
Sample EN-GB_DE-DE.tmx.

NOTED
The sample file is an English-German TM in TMX format that contains approx. 40,000 TUs.

6. Click Next and wait a few seconds for the TMX file to load.
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7. On the next page you can see the language pair of the AutoSuggest dictionary �
(i.e. English - > German). Just click Next to continue.

8. On the page AutoSuggest Dictionary Creation Memory Usage the total number of units to 
process is displayed. The sample TMX file contains over 40,000 units. You may decide to 
reduce the number of units to process. Reducing the number of units to process can be 
helpful when processing very large TMs, which could help avoid memory issues. However, 
for our sample input file this is not required, as it is relatively small. Therefore, just click 
Next to continue.
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9. On the following page click Browse and select the location in which the AutoSuggest 
dictionary is to be created. Select a location that you can find easily, e.g. your desktop, and 
enter a name for the AutoSuggest dictionary file, e.g. EN-DE. 

NOTED
AutoSuggest dictionary files have the extension *.bpm (for bilingual phrase mapping).

10. Click Finish to start the creation of your AutoSuggest dictionary. Depending on the size of 
the TMX file, generation of the AutoSuggest dictionary takes some time (for the sample file 
about 3 minutes).

NOTED
The AutoSuggest dictionary can only be generated, if your input TM contains 10,000 translation units 
or more. TMs with less units do not provide a sufficient basis for reliable phrase extraction.

11. When the generation process is complete, click Close. Open Windows Explorer to view the 
newly-created AutoSuggest dictionary file, e.g. EN-DE.bpm.

FOR MORE INFORMATION
V

How to Create an AutoSuggest Dictionary

SUMMARY

C AutoSuggest dictionaries support the translation process by interactively suggesting relevant words 
and expressions while you are typing.

C AutoSuggest dictionaries can be generated from a TM or a TM in TMX export format.

C The source TM needs to contain at least 10,000 units (i.e. pairs of source and target segments) for 
meaningful phrase extraction.

http://producthelp.sdl.com/SDL_Trados_Studio_2015/client_en/ref/A-G/AutoSuDic.htm
http://producthelp.sdl.com/SDL_Trados_Studio_2015/client_en/setting_preferences/AutoSuggest/Schedule_TM_Phrase_Extraction.htm
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Chapter

CREATING TERMBASES FROM 
EXCEL GLOSSARIES

In this chapter you will learn how to:

C Convert a glossary file in Excel format into an SDL 
MultiTerm termbase

7
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ABOUT CONVERTING EXCEL GLOSSARIES

SDL MultiTerm comes with an additional product called SDL MultiTerm Convert, which allows you to 
convert, for example, Excel glossaries to SDL MultiTerm XML format. This XML format then be imported 
into a termbase.

PREPARING YOUR GLOSSARY FOR CONVERSION

In your sample files folder, i.e. ..\Sample Files\Converting_Glossaries, you find the glossary.xlsx sample file. 
When opened in Microsoft Excel the glossary looks as shown below:

Note that this file already fits the requirements for converting into SDL MultiTerm XML format, i.e.:

C The terms for each language and the values of the descriptive field (i.e. Subject) are listed in separate 
columns.

C The column headers contain the label of each language field and the descriptive field. It is 
important that the column headers match the names that the fields will have in the SDL MultiTerm 
termbase.

CONVERTING THE MICROSOFT EXCEL FILE

Specifying the Input Format and File
To convert the Microsoft Excel glossary take the following steps:

1. First, make sure that the file to convert is NOT open in Microsoft Excel.

2. Launch SDL MultiTerm Convert through Start -> All Programs -> SDL MultiTerm 2019. 
Then click the SDL MultiTerm 2019 Convert application icon.

3. This will open SDL MultiTerm Convert, which is a wizard application. On the first page of 
the wizard, click Next to continue. On the following page click Next again.
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4. On the Available conversion options page select Microsoft Excel format from the available 
input formats, then click Next.

5. On the Specify Files page you select the file to convert. Click the Browse button and select 
the file glossary.xlsx from your sample files location (i.e. ..\Sample Files\Converting_Glossaries) 
by double-clicking it. Then click Next.

NOTED
The other text fields will be filled in automatically. These contain the names of the output file paths, 
most importantly the XML output file, which we will later import into a termbase.
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Specifying the Termbase Fields
1. On the Specify Column Header page, the field names from the column headers in the selected Excel 

file are shown in the Available column header fields list. On this page you need define which 
column headers should be processed as language fields, and which ones contain additional 
(descriptive) information. 

2. Start with the Subject field. Make sure that this field is highlighted in the Available column 
header fields list. 

3. The Subject column contains descriptive information (i.e. no terms), therefore the 
Descriptive fields radio button, which is already pre-selected, applies here. Just change the 
value in the dropdown list below from Text to Picklist.
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NOTED
The data type Text is used for fields that allow for free text, e.g. a definition, note, example, etc. When 
you have a limited number of values (e.g. only a limited number of clients), then use the data type 
Picklist. This is the likely data type for Subject, as a Subject is usually associated with a limited set of 
values, e.g. general, politics, science, etc.

4. Continue with the other columns, i.e. English and German. Let us assume that the terms 
listed in the English column should be stored as English (United Kingdom) in the termbase. 
To do this make sure that English is selected in the Available column header fields list.

5. Then click the Language field radio button, as English is language, not descriptive 
information.

6. From the dropdown list below Language field select English (United Kingdom).

7. Repeat the above step for German, which needs to be assigned to German (Germany). 
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8. Click Next to continue.

Specifying the Entry Structure
1. Descriptive information can be assigned to the entry level (i.e. the top level), if they refer to the entry 

as a whole, i.e. to all terms contained in the entry. Descriptive fields can also be assigned to the term 
level, if they refer only to a particular term. Let us assume that the Subject field value should always 
refer to the whole entry.

2. Highlight Subject in the Available descriptive fields list and select Entry level in the Entry 
structure box. Then click the Add button.

3. Note that the Subject field has now been added under Entry level and therefore above the 
languages. Click Next to continue.
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Starting the Conversion
1. On the Conversion settings summary page click Next.

2. This will start the conversion. Wait for the progress bar to indicate that the conversion is 
finished. 

3. Proceed by clicking Next and then click Finish.

4. Take a quick look at the sample folder that contains your glossary.xslx file. �
SDL MultiTerm Convert has created the following files:

C glossary.xdt: this is the termbase definition file from which we will create a new (empty) 
termbase

C glossary.mtf.xml: this is the termbase content, which we will import into the termbase (which 
we are going to create in the next step)

FOR MORE INFORMATION
V

About SDL MultiTerm Convert

CREATING A NEW TERMBASE

Start SDL MultiTerm if it is not running through Start -> All Programs -> SDL MultiTerm 2019 -> SDL 
MultiTerm 2019 Desktop.

Creating the Termbase File
To start creating the new termbase take the following steps:

1. Switch to the File tab, and then select the New -> Create Termbase.

2. This opens the Save New Termbase dialog box, in which a location and a default name for 
the new termbase is already suggested, i.e. New Termbase.sdltlb.

3. Replace the suggested termbase file name with glossary.sdltb, then click Save.

http://producthelp.sdl.com/SDL_MultiTerm_2015/client_en/SDL_MultiTerm_Convert/About_MultiTerm_Convert.htm
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Loading the Termbase Definition
1. This opens the Termbase Wizard. On the first screen of the wizard just click Next to continue.

2. We will now create the new termbase based on the glossary.xdt termbase definition, which 
SDL MultiTerm Convert has created. To select this termbase definition click the Load an 
existing termbase definition file radio button.

3. Click the Browse button and select the file glossary.xdt from your sample files location. 

4. Then click Next to continue.
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Naming the Termbase
1. On the Termbase Name page, enter a name for your termbase into the Friendly Name text field, e.g. 

User Interface Glossary. 

2. Then click Next to continue.

Languages and Descriptive Fields
1. The Language Fields page lists the languages taken over from the Excel file. Here you just need to 

click Next to continue.

2. You can also skip the next two pages, i.e. Descriptive Fields and Entry Structure by clicking 
Next twice.
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3. On the Wizard Complete page click Finish to create the termbase.

4. Wait a few seconds for the new termbase to be created. Note that the termbase name is 
shown in the application title bar.

FOR MORE INFORMATION
V

About Creating Termbases

Importing the Glossary Content
Note that the newly created termbase is still empty. You need to import the content that you converted 
from the Excel glossary into the termbase. To do this take the following steps:

1. Click the Termbase Management button on the bottom of the Navigation pane.

2. Right-click Import and then select Process from the context menu.

3. On the first page of the Import Wizard click Browse and select the file glossary.mtf.xml, 
which has been created by SDL MultiTerm Convert, from your sample files folder.

http://producthelp.sdl.com/SDL_MultiTerm_2015/client_en/Creating_and_Maintaining_Termbases/Creating_New_Termbases/Default_Termbase_Templates.htm
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4. Then activate the Fast import check box and proceed by clicking Next.

5. On the following page click Next again.

6. Wait for the progress bar to reach 100%. After all entries have been processed click Next, 
and then Finish.

7. Switch back to the Terms view, and the terms from the imported entries are now shown in 
the Browse list.

FOR MORE INFORMATION
V

How to Import Termbase Data

http://producthelp.sdl.com/SDL_MultiTerm_2015/client_en/Creating_and_Maintaining_Termbases/Importing_Termbase_Data/About_the_Import_Wizard.htm
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SUMMARY

C Glossaries in Excel format can be converted to SDL MultiTerm XML through SDL MultiTerm 
Convert, which is a wizard application.

C The field and language names need to be stated in the first row, i.e. in the column headers.

C SDL MultiTerm Convert generates an *.xdt file, which contains the termbase definition and from 
which a termbase can be created.

C SDL MultiTerm Convert also generates an *.xml file, which contains the actual entries, and which 
can be imported into the termbase.



Chapter

LEVERAGING LEGACY 
RESOURCES

The exercise in this chapter demonstrates how you can use the 
translation memory, the termbase, and the AutoSuggest 
dictionary that you created in the previous chapters to translate 
a sample document.

8
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ABOUT THIS EXERCISE

The document for this exercise can be found in your sample files folder, i.e.: ..\Sample Files\Sample 
documents.

This document is an updated version of one of the files that you aligned before. Moreover, it also contains 
terminology that can be found in the converted glossary.

OPENING THE FILE FOR TRANSLATION

Open the file Sample_EN.docx for translatione.g. by pressing Ctrl+Shift+O.

Make sure that you select the corresponding TM, termbase, and the AutoSuggest dictionary that you 
created in the previous chapters.

The Alignment Penalty
Take the following steps:

1. Make sure that your cursor is placed inside the empty target cell of the first segment.
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2. Note that you will get a translation suggestion, which is marked as a 99% fuzzy match. 
Move the mouse pointer over the icon below the match value in the Translation Results 
window.

3. A tooltip will appear to indicates that an alignment penalty of 1% has been applied to current 
translation suggestion. Note that this penalty is by default applied to all translation units that 
come from an alignment. The purpose of the alignment penalty is to alert the user that the 
current translation suggestion comes from an alignment and might not be 100% reliable.

4. However, in this case, the correct translation has been suggested. Therefore, you can 
confirm the current segment without making any changes.

NOTED
Once an aligned unit has been confirmed during translation, it will be offered as a 100% or even a 
CM match the next time that the same segment comes up in a document again.

NOTED
The alignment penalty is also the reason why you will find a lot of 99% matches in the analysis report 
when you run an analysis on the current file.

Analyzing the File
Now run an analysis on the file. Take the following steps:
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1. Click Batch Tasks -> Analyze Files.

2. In the Batch Processing dialog box click Finish, and after the process is complete click Close.

3. When prompted to re-open the file, click Yes.

4. Switch to the Reports view to view the analysis result.

5. Note that most segments can be found in the 95%-99% range, which is due to the 
alignment penalty, as most segments will be 100% matches that have a 1% alignment 
penalty.
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Switch back to the Editor view to translate the rest of the document. For most segments, you will get high 
fuzzy matches that require very little or no editing. For the segments that have no TM match, you should 
get a number of hits from the termbase and/or from the AutoSuggest dictionary, e.g.:

SUMMARY

C The resources that you generated through alignment of legacy documents and conversion of MS 
Excel glossaries can be easily used for processing new documents.

C Translation suggestions that come from an alignment are automatically assigned a penalty of 1% to 
alert users to the fact that the current suggestion might not be 100% trustworthy.

C Once you have confirmed a translation suggestion that originates from an alignment, the alignment 
penalty will no longer be applied, i.e. the translation will be offered as a 100% or CM match the next 
time that the same segment comes up.
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Chapter

FUZZY MATCH REPAIR

In this chapter you will learn:

C What fuzzy match repair is

C How to use fuzzy match repair in your daily work

9
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ABOUT FUZZY MATCH REPAIR

You already know that a TM can provide translation suggestions even if the segment that you need to 
translate is not identical, but only similar to a previously translated segment. In this case, Studio will 
suggest a fuzzy match and highlight the differences between the current and the previously translated 
segment. You then have to adapt the suggested translation manually.

Now imagine the following: Studio automatically modifies the suggested target segment to fit the current 
context, so that you only have minimal or even no post-editing work. This automatic adaptation of fuzzy 
matches is called Fuzzy Match Repair.

Take the following example:

Your TM contains the following source / target segment pair:

Source: Please close the window.

Target: Das Fenster bitte schließen.

Now you need to translate the following segment:

Source: Please open the window.

The only difference between the previous and the current source segment is the fact the verb has changed 
from close to open. After retrieving the suggested translation, you need to manually adapt the target 
segment by manually inserting the target-language equivalent for the word open.

With Fuzzy Match Repair, the corresponding word in the target segment gets replaced automatically. This 
means that you can save even more time when dealing with fuzzy matches. For this to work, of course, 
Studio has to ‘know’ where the words to replace are located in source and target. Furthermore, Studio has 
to ‘know’ which target-language words to insert. For this Studio can draw from the following sources:

1. Fragments from other segments stored in the TM (in our example, other segments in which the 
words open and close occur)

2. Termbase entries that contain the relevant terminology

3. Web-based machine translation systems such as SDL Language Cloud (which we will not be 
using in this exercise)

USING FUZZY MATCH REPAIR

In this section you will see examples of how Fuzzy Match Repair works.

Opening the Sample File, TM, and Termbase
To select the sample file, TM, and termbase, take the following steps:

1. Press the keyboard shortcut combination Ctrl+Shift+O, and browse to the folder ..\Sample 
Files\Studio - Getting Started Part 2\Fuzzy match repair.
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2. Select the file Sample_Document.docx. Select English (United Kingdom) as source and 
German (Germany) as target language. Use the sample TM that you find in the same folder 
as the sample document.

3. Then click the Advanced button in the lower-left corner of the window. In the Project 
Template Settings window select Language Pairs -> All Language Pairs -> Termbases. Then 
click Use -> File-based MultiTerm Termbase to select the termbase that you find under 
..\Sample Files\Fuzzy match repair\Termbase.

4. Click OK twice to open the document in the Editor view.

5. Select All Language Pairs -> Translation Memory and Automated Translation -> Search.

Fuzzy Match Repair in Action
Now that the document is open, take the following steps:
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1. For the first segment you are getting a repaired fuzzy match, which is indicated by the wrench 
symbol in the match value box. In this case, the word adding has been replaced with saving. In the 
Translation Results window, the changes are not only highlighted for the source segment, but also 
for the target segment. This indicates that the target segment has been ‘repaired’ by inserting the 
correct term.

2. You might still have to adapt the suggested translation, but you should have less editing 
work than if you had to ‘repair’ the whole fuzzy match manually. Edit the segment as 
required, and confirm it.

3. For the next segment you are also getting a repaired fuzzy match. The string in TagEditor has 
been removed from the source, as this is an outdated product name. Studio has also 
removed it from the target. Verify whether the repaired fuzzy match is correct, edit it if 
necessary, then confirm it.

4. For segments 3 and 4 you should also get repaired fuzzy match suggestions. Studio has been 
able to repair these matches using segment fragments from other translation units in the 
same TM. Edit the suggested translations as required, and confirm them.
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5. For the last segment you also get a repaired fuzzy match: the outdated product name T-
Window has been replaced with the application. Thanks to the fact that this term has been 
found in the termbase, Studio was able to automatically insert the correct target term into 
the target segment.

6. Edit the suggested translation as required, and confirm it.

Finally, you can save and close the document.

SUMMARY 

C Studio can automatically adapt fuzzy matches, which means less manual editing work for you.

C Studio determines which terms have to be changed in the target segments using segment 
fragments from other translation unit in the TM, terms from a terminology database, or Web-based 
machine translation systems such as SDL Language Cloud.

C Repaired fuzzy matches are highlighted with a wrench symbol to distinguish them from non-
repaired matches.

C For repaired fuzzy matches, the Translation Results window also highlights the changes in the 
target segment, so that you can see what automatic fuzzy match repair has changed.
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Chapter

SDL GROUPSHARE

This chapter provides a quick overview of SDL GroupShare. 
You will learn how to:

C Connect to a GroupShare Server

C Open a project from a GroupShare Server

C Check out and check in a file

10
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ABOUT SDL GROUPSHARE

SDL Trados Studio has the capability to connect to a central SDL GroupShare Server. A GroupShare 
Server allows you to do the following:

C Access centralized projects

C Upload and download files to/from a central server over the Internet or an Intranet

GroupShare facilitates the handling of projects that involve distributed teams. Rather than sending out 
package files to project team members, translators can log on to the server and check out the files that they 
need to process. GroupShare logs which files have been checked out by which user. That way you can 
transparently trace who currently owns which files. The system thereby effectively avoids conflicts, e.g. two 
users changing the same file.

LOGGING IN TO A GROUPSHARE SERVER

Note that the following exercise is only relevant for you if you have access to a GroupShare. To connect to 
a GroupShare Server take the following steps:

1. Switch to the File tab. Then select Setup -> Servers.

2. In the Servers dialog box click Add to add a connection to a GroupShare Server.

3. In the Add SDL Server dialog box enter the server name into the Server Address text field.

4. The default port is 80. If the port number needs to be changed, enter the value into the Port 
text field.
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5. In this example we assume that SDL authentication is used, therefore make sure that the 
Use SDL authentication radio button is selected.

6. Enter the user name and password that was given to you (e.g. by your administrator).

7. If you do not want to be prompted for your credentials every time you open the application, 
then activate the Do not prompt me again check box.

8. Then click OK to connect. If you have been successfully connected, then the server should 
be shown as Available. Now click Close.

OPENING A PROJECT FROM THE SERVER

Now that you are connected to the server you can open projects that have been published through 
GroupShare, and are accessible to authorized users.

To access a server-based project take the following steps:

1. Switch to the Welcome screen, and then click Open GroupShare Project.
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2. This will raise the Open GroupShare Project dialog box. On the left-hand side you will see a 
list of so-called organizations. Projects are usually stored in different organizations (e.g. 
Marketing, User Guides etc.), similar to the way files on a hard disk are stored in different 
folders.

3. Translators and reviewers can be given access to particular organizations. Let us assume that 
the project that you would like to access is called Training Sample Project, which can be 
found in the Training organization. To open this server project, select the Training 
organization, and then click the corresponding project name. Finally, click Next.

4. On the following page you see that a folder has been suggested into which the project 
information file will be downloaded. Leave the suggested location unchanged, and then click 
Finish.

NOTED
In this step you will NOT download the actual files to translate, but just the project information file. 
The files to process need to be downloaded in a separate step (see section below).

5. After the project information has been downloaded to your local PC click Close.
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6. Now switch to the Projects view. 

7. Note that the server project is now listed in the application. The project icon with the green 
globe indicates that this is a GroupShare Server project.

CHECKING OUT FILES

As mentioned before, by opening the project you have just downloaded the information on the project, but 
not the actual project files. The process of downloading files to translate or review is called check-out.

To check out a project file take the following steps:

1. Double-click the project to switch to the Files view.

2. Right-click the first file, and select Check Out from the context menu.
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3. Note that after you have checked out the file it is marked with a specific icon, and the name 
of the user who has checked out the file is stated in the Checked Out To column. By 
checking out the file you have claimed ownership of the document. This means that no 
other translator or reviewer can check out the file now. All authorized users can see who has 
claimed ownership of a project file.

FOR MORE INFORMATION
V

About GroupShare Projects

CHECKING IN FILES

Since checking out a file means that you have downloaded it to your local PC. You can now translate or 
edit it just like any other file that you have opened in Studio. After having translated the file you will want 
to upload it to the GroupShare Server, i.e. check it in.

To check in a project file take the following steps:

1. Make sure that you are back in the Files view. Right-click the file, and then select Check In from the 
context menu.

2. This raises the Check In dialog box. Here you may enter an optional comment. Click Check 
In to upload the file to the server.

3. Note that by checking in you have released ownership of the file, which is now available to, 
for example, a reviewer, an editor, the project manager, etc.

SUMMARY 

C SDL GroupShare helps distributed teams to work more effectively on projects.

C To connect to a GroupShare Server you require the server address and a login.

C Once connected to a server you can open projects that have been published and to which you have 
access.

C Project files and be downloaded (check out) and uploaded (check in) from/to the server. It is 
transparent to all those involved who is currently working on which file.

http://producthelp.sdl.com/SDL_Trados_Studio_2015/client_en/projects_view/Online/About_Project_Server.htm


Chapter

THE SDL APPSTORE

The SDL AppStore is an online platform from which you can 
download useful plugins (most of which are for free) to add 
new functionality to your Studio. This chapter provides a quick 
introduction to the SDL AppStore. You will learn how to:

C Open the SDL AppStore

C Download a plugin

C Install a plugin

C Manage your plugins

11
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NAVIGATING TO THE SDL APPSTORE

The easiest way to find the SDL AppStore is by clicking the corresponding link in the Welcome view of the 
Navigation Pane.

This will open the SDL AppStore in your Web browser:

DOWNLOADING AN APP

Imagine you have heard about a useful plugin called Dictionary Plugin, which allows you to look up online 
dictionaries directly from Studio. To download the plugin take the following steps:

1. Enter the name of the plugin into the search field, i.e. Dictionary Plugin, then press Enter.
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2. Click the icon of the corresponding plugin that appears in the search result(s).

3. Then click Download. You will then be prompted to log in with your SDL user account, or to 
sign up if you have no account with SDL. After logging in you will be able to download the 
plugin to your PC.

INSTALLING A PLUGIN

To safe you the trouble of downloading, we have already placed the plugin into your sample files folder, 
i.e. ..Studio - Getting Started Part 2\Apps. There you will find the *.sdlplugin file, which you need to double-
click. This will open the SDL Plugin Installer:

1. On the first screen click Next.
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2. Accept the terms and conditions, then click Next again.

3. Select the version of Studio for which the plugin should be installed

4. On this screen, you can also decide in which folder the plugin should be installed. The 
option All your domain machines will deploy the plugin to a roaming folder, so that you can 
use it from any PC in a local network. The option Local machines will put the plugin to a 
folder that is only accessible on the local PC. Select your preferred deployment option, then 
click Next.

NOTED
If you have several versions of Studio installed, you can deploy the plugin to all Studio versions.

5. Finally click OK. If Studio is already started, please close the application, and re-start it. The 
plugin will only be available after a re-start.

You can now start using the plugin. In case of our sample plugin, you will find an extra button on the 
Advanced tab in the Editor view, which you can use to look up selected terms in Wiktionary.
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MANAGING PLUGINS

If you download and install a lot of plugins you might want to get an overview of which plug-ins are 
installed, and possibly remove a plugin you no longer need. To manage your plugins take the following 
steps:

1. Switch to the Welcome view.

2. Click Sdl Plugin Management in the Navigation Pane.

3. This will open the following window in which you can view information like: installed 
plugins, version, author, and a button that allows you to uninstall the corresponding plugin.

SUMMARY

C The SDL AppStore offers a big choice of plugins that add new functionality to your Studio, e.g. 
plugins that allow you to look up terms in online dictionaries.

C To download a plugin, you need to have an account with SDL.
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C The plugin file can be installed by double-clicking the plugin file. Studio needs to be restarted before 
you can access the plugin functionality.

C From the Welcome view you can manage and - if required - uninstall plugins.



Chapter

INTERMEDIATE TOPICS -  
OVERVIEW

This chapter provides a quick overview of the topics covered in 
the Intermediate training course for SDL Trados Studio.

12



In te rmed ia te  Top ics  -  Ove rv i ew12

12-2     SDL TRADOS STUDIO GETTING STARTED PART 2
SDL plc Confidential. Copyright ¤�2018 SDL plc.

SDL Trados Studio Intermediate for Translators - Overview
The Intermediate training course covers the following topics:

C Processing multiple files through projects

C Automated project preparation

C Using multiple translation memories

C Find/replace functionality

C More on the display filter function

C Changing the segmentation on the fly (merging and splitting segments)

C Finalizing and completing projects

C Merging multiple files into one

C Reviewing documents (tracking changes)

C Selecting your preferred spell check module

C Automated quality assurance (QA Check)

C Automated terminology verification

C Fine-tuning the auto-propagate settings

C Customizing keyboard shortcuts
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